Last Comment Bug 783574 - IonMonkey: useMethodJIT is false if interpMode is JSINTERP_BAILOUT
: IonMonkey: useMethodJIT is false if interpMode is JSINTERP_BAILOUT
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
: general
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 08:48 PDT by Jan de Mooij [:jandem]
Modified: 2012-08-18 01:26 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.55 KB, patch)
2012-08-17 08:48 PDT, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-08-17 08:48:57 PDT
Created attachment 652783 [details] [diff] [review]
Patch

This caused a huge slowdown on a testcase I was looking at. Doesn't really improve SS/Kraken/V8 though.

It looks like useMethodJIT was added for JM/TM integration, the patch just removes it.
Comment 1 Jan de Mooij [:jandem] 2012-08-18 01:26:14 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/a6c1953435ee

Note You need to log in before you can comment on or make changes to this bug.