Closed
Bug 783701
Opened 14 years ago
Closed 13 years ago
VideoConduit needs to set RFC4585 and KeyFrameReq to PliRtcp
Categories
(Core :: WebRTC: Networking, defect)
Core
WebRTC: Networking
Tracking
()
RESOLVED
DUPLICATE
of bug 816112
People
(Reporter: jesup, Assigned: snandaku)
Details
(Whiteboard: [WebRTC], [blocking-webrtc+])
Attachments
(1 file)
|
3.26 KB,
patch
|
Details | Diff | Splinter Review |
The defaults in the webrtc/trunk code are useless (RFC 3550 RTCP and FirRtp KeyFrameRequests - which are totally useless/fubar and are rejected by libsrtp).
We need to do the same for defaults as webrtcvideoengine.cc in libjingle - set RFC4585, set PliRtcp for KeyFrameReq, and probably also set the MTU (since they do so there). Note that these *really* should come as a result of SDP negotiation, and the default keyframe mode should be periodic iframes, or *maybe* (just maybe) RFC 2302 FIRs in RTCP instead of RTP.
I'll attach a non-compiling patch as a start.
Updated•14 years ago
|
Whiteboard: [WebRTC], [blocking-webrtc+]
| Reporter | ||
Updated•13 years ago
|
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in
before you can comment on or make changes to this bug.
Description
•