Last Comment Bug 783738 - Use Components.results.NS_BINDING_ABORTED instead of hardcoding the value
: Use Components.results.NS_BINDING_ABORTED instead of hardcoding the value
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla17
Assigned To: Phil Ringnalda (:philor)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 21:48 PDT by Phil Ringnalda (:philor)
Modified: 2012-08-18 04:25 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (5.42 KB, patch)
2012-08-17 21:48 PDT, Phil Ringnalda (:philor)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor) 2012-08-17 21:48:53 PDT
Created attachment 653019 [details] [diff] [review]
fix

+++ This bug was initially created as a clone of Bug #454360 +++

Since bug 418406 was nice enough to expose network error constants in Components.results back in 2008, we made use of them rather than hardcoding 0x804b0002 all over the place in JS...

but that's the sort of thing that creeps back in, from people remembering all the years before 2008 instead of the years after it.

https://tbpl.mozilla.org/?tree=Try&rev=ee0aa78db209
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-17 21:59:46 PDT
Comment on attachment 653019 [details] [diff] [review]
fix

Cr is defined in all of the test files, you could use it
Comment 2 Phil Ringnalda (:philor) 2012-08-17 22:15:38 PDT
I did consider using Cr, but it's freshly defined from a tree-wide change, nothing else in the files uses any of the C*s, so using just one down in the middle is a bit risky, and changing them all seemed both intrusive and likely to bring down the wrath of someone with a superstition about not using them.

https://hg.mozilla.org/integration/mozilla-inbound/rev/d11657f18f85
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-08-18 04:25:36 PDT
https://hg.mozilla.org/mozilla-central/rev/d11657f18f85

Note You need to log in before you can comment on or make changes to this bug.