Last Comment Bug 783763 - browser_bug435325.js shouldn't reference nsIDOMWindowUtils, should be moved to /browser/
: browser_bug435325.js shouldn't reference nsIDOMWindowUtils, should be moved t...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla17
Assigned To: Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
:
Mentors:
Depends on: 779680
Blocks: 782892
  Show dependency treegraph
 
Reported: 2012-08-18 05:07 PDT by Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
Modified: 2012-08-21 11:09 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.65 KB, patch)
2012-08-20 22:31 PDT, Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not)
dolske: review+
Details | Diff | Review

Description Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-08-18 05:07:40 PDT
Bug 779680 removed usage of nsIDOMWindowUtils.goOnline() in about:neterror. This had been used to go online when clicking "try again" after a page failed to load due to be in Offline Mode. However, browser_bug435325.js, which tests that functionality, still makes reference to nsIDOMWindowUtils in its log output.

Arguably, that test should be in moved to /browser/ (from docshell), since that functionality was moved into browser chrome.
Comment 1 Philip Chee 2012-08-20 09:48:16 PDT
Is there some sort of B2G API that can be used to kick Firefox online so you don't have to rely on something in /browser ?
Comment 2 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-08-20 16:58:15 PDT
You mean WebAPI? None that I'm aware of, nor any plans. At least in terms of Firefox, Offline Mode is kinda-sorta being slowly deprecated anyway (as evidenced by its move to the Developer Tools menu).
Comment 3 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-08-20 22:31:55 PDT
Created attachment 653657 [details] [diff] [review]
Patch v1
Comment 4 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2012-08-21 00:44:20 PDT
https://hg.mozilla.org/integration/fx-team/rev/bface603ef72
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-08-21 11:09:54 PDT
https://hg.mozilla.org/mozilla-central/rev/bface603ef72

Note You need to log in before you can comment on or make changes to this bug.