Last Comment Bug 783875 - Fix arm detection on OpenBSD
: Fix arm detection on OpenBSD
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: ARM OpenBSD
: -- normal (vote)
: mozilla17
Assigned To: Landry Breuil (:gaston)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 05:47 PDT by Landry Breuil (:gaston)
Modified: 2012-08-26 19:25 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix arm detection on openbsd (945 bytes, patch)
2012-08-19 05:49 PDT, Landry Breuil (:gaston)
benjamin: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2012-08-19 05:47:03 PDT
On OpenBSD/armish and OpenBSD/zaurus, uname -p returns 'arm'. We've been shipping a patch to xpcom/reflect/xptcall/src/md/unix/Makefile.in fixing this since ages (see http://www.openbsd.org/cgi-bin/cvsweb/ports/www/mozilla-firefox/patches/patch-xpcom_reflect_xptcall_src_md_unix_Makefile_in) :

-ifneq (,$(filter OpenBSDarmish OpenBSDzaurus,$(OS_ARCH)$(OS_TEST)))
+ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDarm)

While atm firefox doesnt build on OpenBSD/arm platforms for various reasons, it costs nothing to fix it now.
Comment 1 Landry Breuil (:gaston) 2012-08-19 05:49:18 PDT
Created attachment 653171 [details] [diff] [review]
Fix arm detection on openbsd
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-08-26 19:25:34 PDT
https://hg.mozilla.org/mozilla-central/rev/260d65801b22

Note You need to log in before you can comment on or make changes to this bug.