Last Comment Bug 783909 - Fixup app update timer prefs
: Fixup app update timer prefs
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 16 Branch
: x86_64 Linux
: -- normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-19 13:35 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-08-22 23:15 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (3.28 KB, patch)
2012-08-19 13:35 PDT, Mark Finkle (:mfinkle) (use needinfo?)
blassey.bugs: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
Details | Diff | Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2012-08-19 13:35:58 PDT
Created attachment 653201 [details] [diff] [review]
patch

Fennec has used the app.update.timer pref for a long time. It was used to start the UpdateTimer system which is used to kickoff many of the background timers used by Gecko, including the update and blocklist pings.

This pref was dropped and a new one added (app.update.timerFirstInterval). The new pref was added to mobile.js, but was placed in the MOZ_UPDATER section, which is only used for non-official builds (nightly and aurora). Therefore, Fennec was using the default 120 seconds for official builds.

This patch:
* removes the unused app.update.timer pref
* adds the two new prefs outside the MOZ_UPDATER section of mobile.js using the same 30secs as used by b2g.
* cleans up a dupe of app.update.showInstallUI

If my theory about Fennec using 120 secs before doing a blocklist ping is true, we should see an affect on ADIs.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-19 21:18:31 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/4d22460a96ea
Comment 2 Ed Morley [:emorley] 2012-08-20 08:54:50 PDT
https://hg.mozilla.org/mozilla-central/rev/4d22460a96ea
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-21 22:18:39 PDT
Comment on attachment 653201 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Since app.update.timer is no longer used, we stopped getting pings in 30sec and started getting pings in 2mins (the default) for release builds. On mobile devices this might be too long to get a ping before the browser is closed.
User impact if declined: should only affect blocklist ping timing
Testing completed (on m-c, etc.): a few nights
Risk to taking this patch (and alternatives if risky): might cause changes in reported ADIs (more accurate)
String or UUID changes made by this patch: none
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-22 15:07:12 PDT
Comment on attachment 653201 [details] [diff] [review]
patch

Too late for beta, we're already signed off for release on our b6. Approving for Aurora.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2012-08-22 23:15:55 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/94e84c4f1c8e

Note You need to log in before you can comment on or make changes to this bug.