Last Comment Bug 783971 - [gcli] GCLI popup not appearing at its correct position
: [gcli] GCLI popup not appearing at its correct position
Status: RESOLVED FIXED
[gclicommands][fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Firefox 18
Assigned To: Michael Ratcliffe [:miker] [:mratcliffe]
:
Mentors:
Depends on:
Blocks: GCLICMD
  Show dependency treegraph
 
Reported: 2012-08-20 01:57 PDT by Girish Sharma [:Optimizer]
Modified: 2012-09-06 05:56 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
One example (101.05 KB, image/png)
2012-08-20 01:57 PDT, Girish Sharma [:Optimizer]
no flags Details
Fix (10.47 KB, patch)
2012-08-29 06:51 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
jwalker: review+
Details | Diff | Review
Added extra comments (12.43 KB, patch)
2012-08-30 03:04 PDT, Michael Ratcliffe [:miker] [:mratcliffe]
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Girish Sharma [:Optimizer] 2012-08-20 01:57:39 PDT
Created attachment 653310 [details]
One example

1. type any command 
2. while typing its options, the popup sometimes appear at wrong position. It also overlaps the input area sometimes.

This happens for all boolean options, for options of commands that are not valid and for some other cases that I am unable to pin point.

try these commands :
a. restart t
b. screenshot abc g
c. asdas era
d. screenshot abc 10
Comment 1 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-20 03:30:23 PDT
I am unable to reproduce this on Linux. Is there anybody that can try this on Windows?
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-22 07:25:44 PDT
I can reproduce this on Windows & OSX but not on Linux.
Comment 3 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-29 06:51:19 PDT
Created attachment 656424 [details] [diff] [review]
Fix

There is a tooltip bug on Windows and Linux that prevents them from being positioned properly. There is a panel bug on Linux that causes ugly focus issues. We now use a tooltip on Linux and a panel on OSX & Windows. I know it is ugly but the key point is that it works.

If a panel has no content and no height it is not shown when openPopup is called on Windows and OSX ... this was stopping the panel from appearing the first time it was shown (bug 692348). Setting the panel's height to 1px before calling openPopup fixes the issue as we resize it ourselves anyway.
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-29 07:24:48 PDT
Comment on attachment 656424 [details] [diff] [review]
Fix

Review of attachment 656424 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Please could you add a slab of docs to the function that lets people unravel what is going on? Particularly useful would be links to bugs etc. Imagine you have a bad memory and have to look at this code in a years time...
Comment 5 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-30 03:04:09 PDT
Created attachment 656794 [details] [diff] [review]
Added extra comments

Added comments as requested
Comment 6 Paul Rouget [:paul] 2012-08-30 06:44:06 PDT
https://hg.mozilla.org/integration/fx-team/rev/765c575daef9
Comment 7 Victor Porof [:vporof][:vp] 2012-08-30 11:48:50 PDT
https://hg.mozilla.org/mozilla-central/rev/765c575daef9
Comment 8 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-30 13:32:56 PDT
We should also get this into Aurora & Beta if possible.
Comment 9 Victor Porof [:vporof][:vp] 2012-08-30 13:46:25 PDT
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #8)
> We should also get this into Aurora & Beta if possible.

Care to request approval?
Comment 10 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-30 16:17:23 PDT
From who?
Comment 11 Michael Ratcliffe [:miker] [:mratcliffe] 2012-09-04 03:35:41 PDT
Comment on attachment 656794 [details] [diff] [review]
Added extra comments

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Linux Window manager bugs plus Windows and OSX tooltip bugs.
User impact if declined: Panels will be opened in the wrong location ... very ugly.
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Comment 12 Alex Keybl [:akeybl] 2012-09-04 06:47:36 PDT
Comment on attachment 656794 [details] [diff] [review]
Added extra comments

[Triage Comment]
If this is truly a no-risk patch, let's land on branches. If you'd like to reconsider that evaluation, we'd want to know more info about when this originally regressed before landing.
Comment 13 Michael Ratcliffe [:miker] [:mratcliffe] 2012-09-06 05:23:08 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/c14915756148
Comment 14 Michael Ratcliffe [:miker] [:mratcliffe] 2012-09-06 05:56:47 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/7ba553cf616d

Note You need to log in before you can comment on or make changes to this bug.