Last Comment Bug 784126 - Fix JSDOMParser textContent setter
: Fix JSDOMParser textContent setter
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: Reader View (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 17
Assigned To: Brian Nicholson (:bnicholson) (PTO through August 1)
:
Mentors:
Depends on:
Blocks: 779796
  Show dependency treegraph
 
Reported: 2012-08-20 12:46 PDT by Brian Nicholson (:bnicholson) (PTO through August 1)
Modified: 2012-08-24 00:51 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Fix JSDOMParser textContent setter (1.00 KB, patch)
2012-08-20 12:48 PDT, Brian Nicholson (:bnicholson) (PTO through August 1)
lucasr.at.mozilla: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Brian Nicholson (:bnicholson) (PTO through August 1) 2012-08-20 12:46:52 PDT
The textContent setter is incorrectly called "textContext". Also, we should clear the parentNode for its children when we replace the childNodes.
Comment 1 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-08-20 12:48:01 PDT
Created attachment 653483 [details] [diff] [review]
Fix JSDOMParser textContent setter
Comment 2 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-08-20 21:39:12 PDT
Comment on attachment 653483 [details] [diff] [review]
Fix JSDOMParser textContent setter

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 779796
User impact if declined: some parsed articles may show up incorrectly
Testing completed (on m-c, etc.): none yet
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Comment 3 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-08-22 10:16:30 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/fcb1cb11935f
Comment 4 Ed Morley [:emorley] 2012-08-23 03:50:09 PDT
https://hg.mozilla.org/mozilla-central/rev/fcb1cb11935f
Comment 5 Brian Nicholson (:bnicholson) (PTO through August 1) 2012-08-24 00:51:17 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/5a95d677c250

Note You need to log in before you can comment on or make changes to this bug.