Note: There are a few cases of duplicates in user autocompletion which are being worked on.

plugins.click_to_play = true does not block anything when Adblock Plus is installed

VERIFIED FIXED

Status

()

Core
Plug-ins
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: tonymec, Assigned: johns)

Tracking

(Blocks: 1 bug, {regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0 SeaMonkey/2.14a1 ID:20120820003006 c-c:8e502ee509af m-c:c676b554c7bb

Reproducible: Didn't try.

Steps to reproduce (AFAICT):
0. Check that user.js (in the profile) includes the line
user_pref("plugins.click_to_play", true); // set it again at every startup
1. In about:config, make sure that the followings prefs are set as follows:
plugins.click_to_play == true
browser.tabs.warnOnClose == true
browser.warnOnQuit == true
browser.warnOnRestart == true
2. Load at least two tabs, including at least one with embedded Flash. (I had 64 tabs in toto, many of them on bugzilla.mozilla.org bug pages. If it's a race problem, more tabs might make the problem more visible.)
3. File → Quit
4. When the popup comes up, click "Save and Quit".
5. Wait until the application is fully closed (Windows Task Manager, KDE System Guard, GNOME System Monitor, or similar, will display a sharp drop in both RAM and CPU use when that happens; and their processes list, which you should sort by process name, will not show the process you just quit).
6. Start again.

Actual result: The embedded Flash player is running.

Expected result: The embedded Flash player should display a click-to-play placeholder.

Additional info: I used http://users.skynet.be/antoine.mechelynck/ which has an embedded Flash player linking to deviantart.com; but (in case you don't see it without a deviantArt account) doesn't Facebook also use Flash? Or YouTube?
P.S. After checking about:config (and plugins.click_to_play _is_ true), either reloading my skynet.be homepage or loading a YouTube page e.g. http://www.youtube.com/watch?v=wD_vLRkybWU (Vivaldi Recorder Concerto in D major RV92), starts the video immediately.

I would have expected a click-to-play placeholder. I know there are some problems with starting Flash in click-to-play mode, but the workaround consisting of temporarily toggling the pref to false then reloading the Flash page works even with the bug.
Blocks: 738698
What addons do you have installed? (This might be related to or the same as bug 782644).
The following is in Firefox instead:

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
http://hg.mozilla.org/mozilla-central/rev/c676b554c7bb

Problem doesn't happen in an almost fresh profile. But after installing Adblock Plus 2.1.2 it does.

In reply to comment #2: We had a mid-air collision, but great minds think alike ;-)
Blocks: 782644, 467520
Keywords: regression
Summary: plugins.click_to_play = true does not apply do session reload → plugins.click_to_play = true does not block anything when Adblock Plus is installed
(Assignee)

Comment 4

5 years ago
This is most likely a dupe of bug 782644
Assignee: nobody → jschoenick
No longer blocks: 782644
Status: NEW → ASSIGNED
Depends on: 782644
OS: Linux → All
Hardware: x86_64 → All
Normal behaviour comes back after disabling the restartless Adblock Plus AND RESTARTING, see bug 747186 comment #13 and #14.

Comment 6

5 years ago
What about NoScript, GreaseMonkey or my minimal content policy (https://adblockplus.org/trash/testpolicy.xpi)? If the problem is reproducible with these extensions as well then it is quite definitely a dupe of bug 782644.
(In reply to Wladimir Palant from comment #6)
> What about NoScript, GreaseMonkey or my minimal content policy
> (https://adblockplus.org/trash/testpolicy.xpi)? If the problem is
> reproducible with these extensions as well then it is quite definitely a
> dupe of bug 782644.

After restarting with Adblock Plus disabled and the above extension enabled, the same symptoms are visible, viz., embedded Flash starts notwithstanding whatever plugins.click_to_play and the domain's "Activate Plugins" are set to. I didn't check other extensions. Without the addons, the behaviour is as follows:

                             | CTP true           CTP false
-----------------------------+--------------------------------
Activate Plugins = Default   | CTP Lego block     Flash
Activate Plugins = Allow     | Flash              Flash
Activate Plugins = Block     | featureless        Flash
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 782644
Now that bug 782644 is FIXED, this one has disappeared too. => VERIFIED.
Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.