Last Comment Bug 784381 - Build bustage for comm-central - SHA1.h - Cannot open include file: 'stdint.h'
: Build bustage for comm-central - SHA1.h - Cannot open include file: 'stdint.h'
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MFBT (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla17
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Mentors:
Depends on:
Blocks: 781627
  Show dependency treegraph
 
Reported: 2012-08-21 09:20 PDT by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-08-21 19:09 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
use mozilla/StandardInteger.h (837 bytes, patch)
2012-08-21 09:38 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Ms2ger: review+
Details | Diff | Review

Description Mike Conley (:mconley) - (needinfo me!) 2012-08-21 09:20:39 PDT
Noticed this recently on my Windows machine:

c:\Users\mconley\mozilla\thunderbird\mozilla\config\rules.mk:1024:0$ cl InvokeClWithDependencyGeneration cl -FoSHA1.obj -c   -DIMPL_MFBT -DMOZ_THUNDERBIRD=1  -I../../../thunderbird/mozilla/m
fbt -I. -I../dist/include  -Ic:/Users/mconley/mozilla/o-nodbg/mozilla/dist/include/nspr -Ic:/Users/mconley/mozilla/o-nodbg/mozilla/dist/include/nss        -TP -nologo -W3 -Gy -Fdgenerated.pd
b -wd4800 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -MD            -FI ../dist/include/mozilla-config.h -DMOZILLA_CLIENT c:/Users/mconley/mozilla/o-nodbg/mozilla/mfbt/../
../../thunderbird/mozilla/mfbt/SHA1.cpp
SHA1.cpp
c:\Users\mconley\mozilla\o-nodbg\mozilla\dist\include\mozilla/SHA1.h(27) : fatal error C1083: Cannot open include file: 'stdint.h': No such file or directory
2
Traceback (most recent call last):
  File "c:\Users\mconley\mozilla\thunderbird\mozilla\build\pymake\pymake\process.py", line 224, in run
    rv = m.__dict__[self.method](self.argv)
  File "../../../thunderbird/mozilla/build\cl.py", line 45, in InvokeClWithDependencyGeneration
    sys.exit(ret)
SystemExit: 2
None
c:\Users\mconley\mozilla\thunderbird\mozilla\config\rules.mk:1024:0: command 'cl InvokeClWithDependencyGeneration cl -FoSHA1.obj -c   -DIMPL_MFBT -DMOZ_THUNDERBIRD=1  -I../../../thunderbird/
mozilla/mfbt -I. -I../dist/include  -Ic:/Users/mconley/mozilla/o-nodbg/mozilla/dist/include/nspr -Ic:/Users/mconley/mozilla/o-nodbg/mozilla/dist/include/nss        -TP -nologo -W3 -Gy -Fdgen
erated.pdb -wd4800 -we4553 -GR-  -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -O1 -Oy -MD            -FI ../dist/include/mozilla-config.h -DMOZILLA_CLIENT c:/Users/mconley/mozilla/o-nodbg/mozilla
/mfbt/../../../thunderbird/mozilla/mfbt/SHA1.cpp' failed, return code 2
<mfbt.lib.desc>: Found error
<libs>: Found error

I believe this is caused by bug 781627 landing.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-08-21 09:21:56 PDT
what version of msvc are you using? I think vlad noticed something similar.
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-08-21 09:23:07 PDT
I'm using msvc9. Am I behind the times?
Comment 3 :Ms2ger 2012-08-21 09:23:55 PDT
Needs to include mozilla/StandardInteger.h...
Comment 4 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-08-21 09:38:07 PDT
Created attachment 653797 [details] [diff] [review]
use mozilla/StandardInteger.h

https://tbpl.mozilla.org/?tree=Try&rev=58317382daba
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-21 19:09:31 PDT
https://hg.mozilla.org/mozilla-central/rev/27b3a3e33f92

Note You need to log in before you can comment on or make changes to this bug.