If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash if you close the window during onLoad DOM event.

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
UI Design
P1
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Jean-Francois Ducarroz)

Tracking

({crash})

Trunk
mozilla0.9.1
All
Mac System 8.5
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
The progress dialog used during message compose send or save sometime need to
close itsef when it process an onLoad event. The problem is that we start
crashing recently when doing that, use to work fine. The crash occurs in
DocumentViewerImpl::LoadComplete when calling mPreshell->UnsuppressPainting
because the documentViewer object itself has been destroyed! Looks like we need
to protect ourself againg "auto-destruction" by adding addref/release in this
function. I'll attach a testcase...
(Assignee)

Updated

17 years ago
Keywords: crash, mailtrack
(Assignee)

Comment 1

17 years ago
Created attachment 32833 [details] [diff] [review]
Sample xul window that reproduce the problem
(Assignee)

Comment 2

17 years ago
Save the attachment above as .xul and open it in the browser, yoy will crash.

nominating nsbeta1 as this is blocking the landing of the progress dialog in
mailnews.
Keywords: nsbeta1
QA Contact: sairuh → jrgm

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 3

17 years ago
nominating nsbeta1 as this is blocking bug 28348. David, if you want, I can take
care of it!
Blocks: 28348
(Assignee)

Comment 4

17 years ago
Created attachment 33696 [details] [diff] [review]
proposed fix, v1

Comment 5

17 years ago
sr=hyatt
Assignee: hyatt → ducarroz
Status: ASSIGNED → NEW
(Assignee)

Comment 6

17 years ago
R=sspitzer

Updated

17 years ago
Priority: -- → P1
Whiteboard: [nsbeta1+]
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta1+] → [nsbeta1+]Have fix
(Assignee)

Comment 7

17 years ago
Fixed and checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta1+]Have fix → [nsbeta1+]

Comment 8

17 years ago
verified

win2k: 2001060509
linux: 2001060511
macos: 2001060503
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.