Last Comment Bug 784487 - calendar-multiget request is not correctly formatted
: calendar-multiget request is not correctly formatted
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Provider: CalDAV (show other bugs)
: Lightning 1.7
: All All
: -- critical (vote)
: 1.7
Assigned To: Jean-Louis Dupond
:
:
Mentors:
Depends on:
Blocks: 754164
  Show dependency treegraph
 
Reported: 2012-08-21 13:43 PDT by Jean-Louis Dupond
Modified: 2012-08-22 08:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
This patch fixes the calendar-multiget request. (661 bytes, patch)
2012-08-21 13:43 PDT, Jean-Louis Dupond
philipp: review+
philipp: approval‑calendar‑aurora+
philipp: approval‑calendar‑beta+
Details | Diff | Splinter Review

Description Jean-Louis Dupond 2012-08-21 13:43:18 PDT
Created attachment 653926 [details] [diff] [review]
This patch fixes the calendar-multiget request.

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120820141800

Steps to reproduce:

With the new lightning plugin, i'm unable to get any calendar data from the CalDAV server.
The issue was caused by commit http://hg.mozilla.org/releases/comm-beta/rev/a182ec1d232f

The calendar-multiget request should FIRST list its 'prop's it needs, and AFTER that it should print the href's.
This is now the other way around, which causes issues getting the data from the CalDAV server.


Actual results:

No calendar data could be found


Expected results:

All calendar items should show.
Comment 1 Philip Chee 2012-08-22 08:12:17 PDT
Regression from Bug 754164.
Comment 2 Philipp Kewisch [:Fallen] 2012-08-22 08:23:20 PDT
Comment on attachment 653926 [details] [diff] [review]
This patch fixes the calendar-multiget request.

I'm surprised this makes a difference. Just in time, I was just about to start the release builds.
Comment 3 Philipp Kewisch [:Fallen] 2012-08-22 08:25:36 PDT
Pushed to comm-central changeset 06e3e6f847ae
Comment 4 Philipp Kewisch [:Fallen] 2012-08-22 08:26:02 PDT
Backported to releases/comm-aurora changeset 3ff340786504
Comment 5 Philipp Kewisch [:Fallen] 2012-08-22 08:26:25 PDT
Backported to releases/comm-beta changeset c45b2cea68a6

Note You need to log in before you can comment on or make changes to this bug.