Last Comment Bug 784509 - [WebAPI] WebTelephony: Develop automated tests to verify the various call state transitions
: [WebAPI] WebTelephony: Develop automated tests to verify the various call sta...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Robert Wood [:rwood]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 14:38 PDT by Robert Wood [:rwood]
Modified: 2012-08-27 19:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch 1 of 10 (6.71 KB, patch)
2012-08-22 12:31 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 2 of 10 (3.44 KB, patch)
2012-08-22 12:33 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 3 of 10 (3.89 KB, patch)
2012-08-22 12:34 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 4 of 10 (3.13 KB, patch)
2012-08-22 12:34 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 5 of 10 (4.43 KB, patch)
2012-08-22 12:35 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 6 of 10 (2.59 KB, patch)
2012-08-22 12:36 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 7 of 10 (4.24 KB, patch)
2012-08-22 12:36 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 8 of 10 (7.25 KB, patch)
2012-08-22 12:37 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 9 of 10 (3.67 KB, patch)
2012-08-22 12:37 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 10 of 10 (5.06 KB, patch)
2012-08-22 12:38 PDT, Robert Wood [:rwood]
jgriffin: review-
Details | Diff | Splinter Review
Patch 9 of 10 VER2 (3.43 KB, patch)
2012-08-24 13:45 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review
Patch 10 of 10 VER2 (4.86 KB, patch)
2012-08-24 13:46 PDT, Robert Wood [:rwood]
jgriffin: review+
Details | Diff | Splinter Review

Description Robert Wood [:rwood] 2012-08-21 14:38:35 PDT
Develop more B2G WebTelephony WebAPI tests, to verify the various call state transitions.  Refer to the telephony call state transitions diagram found on the WebTelephony API wiki page: https://wiki.mozilla.org/WebAPI/WebTelephony
Comment 1 Robert Wood [:rwood] 2012-08-22 12:31:59 PDT
Created attachment 654319 [details] [diff] [review]
Patch 1 of 10
Comment 2 Robert Wood [:rwood] 2012-08-22 12:32:51 PDT
Adding 10 new B2G WebTelephony tests - each test as its own patch.  The last patch will include the changes to the manifest.ini.
Comment 3 Robert Wood [:rwood] 2012-08-22 12:33:32 PDT
Created attachment 654321 [details] [diff] [review]
Patch 2 of 10
Comment 4 Robert Wood [:rwood] 2012-08-22 12:34:07 PDT
Created attachment 654322 [details] [diff] [review]
Patch 3 of 10
Comment 5 Robert Wood [:rwood] 2012-08-22 12:34:58 PDT
Created attachment 654323 [details] [diff] [review]
Patch 4 of 10
Comment 6 Robert Wood [:rwood] 2012-08-22 12:35:28 PDT
Created attachment 654325 [details] [diff] [review]
Patch 5 of 10
Comment 7 Robert Wood [:rwood] 2012-08-22 12:36:01 PDT
Created attachment 654326 [details] [diff] [review]
Patch 6 of 10
Comment 8 Robert Wood [:rwood] 2012-08-22 12:36:30 PDT
Created attachment 654327 [details] [diff] [review]
Patch 7 of 10
Comment 9 Robert Wood [:rwood] 2012-08-22 12:37:03 PDT
Created attachment 654328 [details] [diff] [review]
Patch 8 of 10
Comment 10 Robert Wood [:rwood] 2012-08-22 12:37:31 PDT
Created attachment 654329 [details] [diff] [review]
Patch 9 of 10
Comment 11 Robert Wood [:rwood] 2012-08-22 12:38:03 PDT
Created attachment 654330 [details] [diff] [review]
Patch 10 of 10
Comment 12 Jonathan Griffin (:jgriffin) 2012-08-23 12:00:51 PDT
Comment on attachment 654330 [details] [diff] [review]
Patch 10 of 10

Review of attachment 654330 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/telephony/test/marionette/test_outgoing_remote_hangup_held.js
@@ +38,5 @@
> +  runEmulatorCmd("gsm list", function(result) {
> +    log("Call list is now: " + result);
> +    is(result[0], "outbound to  " + outNumber + " : unknown");
> +    is(result[1], "OK");
> +    verifyAlerting();

Does this work reliably?  This sets up the onalerting event handler after the dial command has had a chance to do its thing.  I would imagine there is a chance that the alerting event could happen before the event handler is set up, since waiting for the runEmulatorCmd callback gives it a window in which events can be processed.  It's probably better to structure this part something like https://mxr.mozilla.org/mozilla-central/source/dom/telephony/test/marionette/test_outgoing_hangup_alerting.js#28.  This applies to the other tests that use onalerting as well.
Comment 13 Robert Wood [:rwood] 2012-08-24 07:12:41 PDT
Oh, good point - I will make the changes, thanks Jonathan!
Comment 14 Robert Wood [:rwood] 2012-08-24 13:45:10 PDT
Created attachment 655135 [details] [diff] [review]
Patch 9 of 10 VER2

Fixed the test in patch 9, attached new / replacement patch 9.
Comment 15 Robert Wood [:rwood] 2012-08-24 13:46:31 PDT
Created attachment 655136 [details] [diff] [review]
Patch 10 of 10 VER2

Fixed test in patch 10, attached replacement patch 10.
Comment 16 Jonathan Griffin (:jgriffin) 2012-08-24 14:59:04 PDT
Comment on attachment 655136 [details] [diff] [review]
Patch 10 of 10 VER2

Review of attachment 655136 [details] [diff] [review]:
-----------------------------------------------------------------

Looks much better, thanks!  I'll land this shortly.
Comment 17 Jonathan Griffin (:jgriffin) 2012-08-27 10:03:23 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/72e95bee76fa
Comment 18 Ryan VanderMeulen [:RyanVM] 2012-08-27 19:18:48 PDT
https://hg.mozilla.org/mozilla-central/rev/72e95bee76fa

Note You need to log in before you can comment on or make changes to this bug.