Last Comment Bug 784512 - Per input: reports of slowness is up about 100% in Firefox 15 vs 14
: Per input: reports of slowness is up about 100% in Firefox 15 vs 14
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: All All
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
Mentors:
Depends on: 785117
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 14:42 PDT by [:Cww]
Modified: 2013-04-01 12:26 PDT (History)
25 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
Mentions of slow in input for firefox 15 over the last 3 weeks (51.85 KB, text/plain)
2012-08-21 14:42 PDT, [:Cww]
no flags Details
memory_resident regression (22.38 KB, image/png)
2012-08-22 16:36 PDT, (dormant account)
no flags Details
14.0.1 memory data with about:telemetry (47.51 KB, image/png)
2012-08-23 06:14 PDT, Virgil Dicu [:virgil] [QA]
no flags Details
15b6 memory data with about:telemetry (43.79 KB, image/png)
2012-08-23 06:16 PDT, Virgil Dicu [:virgil] [QA]
no flags Details
about:telemetry memory metrics (384.35 KB, text/plain)
2012-08-23 09:56 PDT, Ioana (away)
no flags Details

Description [:Cww] 2012-08-21 14:42:46 PDT
Created attachment 653962 [details]
Mentions of slow in input for firefox 15 over the last 3 weeks

Running a statistical analysis of word frequencies in input, we have twice as much feedback mentioning slow|slowly|speed|forever in 15 relative to 14.

Attached is the actual comments. A lot of people seem to mention games (Facebook/zynga poker in particular) but there are also a number of people mentioning that loading pages/videos is slow.
Comment 1 Alex Keybl [:akeybl] 2012-08-22 10:22:31 PDT
Adding qawanted (for Zynga Poker and FB games) and also pinging the metrics team (page loads) to get some testing around this.
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 10:25:18 PDT
Is this problem specific to Mac or was the platform field just autofilled?
Comment 3 Lawrence Mandel [:lmandel] (use needinfo) 2012-08-22 10:36:17 PDT
I reviewed the feedback (attached). The themes seem to be:
- slow downloads
- slow page loads
- frequent crashes
- flash issues
- high ram usage
- slow start-up
- slow games/videos
- slow search
- mentions of a number of sites including facebook, twitter, tumblr, and more
- slower than previous versions
Comment 4 bhavana bajaj [:bajaj] 2012-08-22 10:41:37 PDT
It would be best use of time to start testing win 7 as most of the user comments in the attachment are from windows users.
Comment 5 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 11:01:50 PDT
Thanks everyone. I'll look into this today. If I don't find any leads I'll hand it off to Softvision overnight to do some testing. Note that we've had two Flash testdays in the last month and have been dogfooding Flash 11.4 for a couple of weeks with no internal reports of performance degradation. 

It might be useful to do some outreach and asking for dogfooding/feedback from a broader audience in parallel to QA investigating this issue. In fact, it would probably be prudent given how close we are to release.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 11:17:23 PDT
I've put a call out to all QA employees to solicit for help here. It would be great if other teams could follow suit. The wider net we cast, the more likely we are to find something.
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 11:24:31 PDT
I accidentally switched my Windows 7 VM into Unity mode received a plugin hang/crash while playing Zynga Poker on Facebook. I was using Firefox 15.0b6 and Flash 11.4.402.265. As of yet I've not been able to reproduce, but here are the reports:

bp-5fb7669a-9ac5-4dee-b793-b7dc22120822
bp-34dc8d61-6c80-41cf-8f23-e16d32120822
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 11:40:22 PDT
I *may* have found a test, though this might just be exaggerated by my VM.

Steps:
1. Clear your caches
2. Log in to Facebook
3. Search for and load "Zynga Slingo"
4. In the Zynga apps bar at the top, select "The Ville"
> The Ville opens in a new tab
5. Scroll with touchpad up and down repeatedly

Result:
Firefox 14.0.1 - scrolling is fluid
Firefox 15.0b6 - scrolling is choppy

Can someone please try if they can reproduce this?
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 11:54:33 PDT
Comment 8 might be a red herring, I retested 14.0.1 and it gets choppy scrolling as well.
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-08-22 12:00:55 PDT
I'm definitely seeing some minor hangs for a few seconds, particularly when a Flash game is loading and activities like scrolling, switching tabs, closing tabs, opening tabs, quitting Firefox. However, these hangs seem no worse in Firefox 15.0b6 then in 14.0.1.

Unfortunately, I have to get back to working on QA sign-off for 15.0b6. Hopefully someone else can jump in here and help out.
Comment 11 [:Cww] 2012-08-22 12:50:03 PDT
I have some telemetry data.

HTTP_COMPLETE_LOAD_NET:

Median has gone from 274ms to 311ms

HTTP_PAGE_COMPLETE_LOAD:

Median has gone from 245ms - 291ms
Comment 12 (dormant account) 2012-08-22 16:33:34 PDT
(In reply to [:Cww] from comment #11)
> I have some telemetry data.
> 
> HTTP_COMPLETE_LOAD_NET:
> 
> Median has gone from 274ms to 311ms
> 
> HTTP_PAGE_COMPLETE_LOAD:
> 
> Median has gone from 245ms - 291ms

In addition to the higher median, from the histograms it does look like there are more values right of median in ff15 than 14.
Additionally HTML_FOREGROUND_REFLOW_MS is slower in 15, as is HTML_BACKGROUND_REFLOW_MS.
Comment 13 (dormant account) 2012-08-22 16:36:16 PDT
Created attachment 654419 [details]
memory_resident regression

Looks like we improved memory usage on extreme end, but our normal memory usage went up. This may explain why pageloading is slower.
Comment 14 (dormant account) 2012-08-22 16:40:00 PDT
(In reply to Taras Glek (:taras) from comment #13)
> Created attachment 654419 [details]
> memory_resident regression
> 
> Looks like we improved memory usage on extreme end, but our normal memory
> usage went up. This may explain why pageloading is slower.

Looks like MEMORY_JS_GC_HEAP went up..however GC_MS is down in 15. No idea what's causing this, but ff15 does indeed seem slower at loading pages and is using more memory.
Comment 15 (dormant account) 2012-08-22 16:53:35 PDT
PAGE_FAULTS_HARD are about 1% more common in firefox 15. This means that on mac/linux we are swapping more often. The windows low memory notifications became more common too(but there the difference is <0.0003%..ie noise)

HTTP_PAGE_CACHE_READ_TIME got a few percent worse too.
Comment 16 Virgil Dicu [:virgil] [QA] 2012-08-23 06:14:43 PDT
Created attachment 654588 [details]
14.0.1 memory data with about:telemetry

Ubuntu 12.04.
Used about:telemetry add-on to gather some memory data on my system. Used the same profile and loaded the same pages (facebook games- bejeweled blitz and war commander and 3 youtube videos).
Didn't spot any noticeable difference between the builds while loading the same sites - there was an expected lag when loading a few games and videos in different tabs, but no noticeable difference.
Comment 17 Virgil Dicu [:virgil] [QA] 2012-08-23 06:16:34 PDT
Created attachment 654590 [details]
15b6 memory data with about:telemetry

There are a few items in memory with some differences between builds. I'll leave it to someone who knows them better to interpret them.
Comment 18 Paul Silaghi, QA [:pauly] 2012-08-23 06:19:56 PDT
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> I *may* have found a test, though this might just be exaggerated by my VM.
> 
> Steps:
> 1. Clear your caches
> 2. Log in to Facebook
> 3. Search for and load "Zynga Slingo"
> 4. In the Zynga apps bar at the top, select "The Ville"
> > The Ville opens in a new tab
> 5. Scroll with touchpad up and down repeatedly
> 
> Result:
> Firefox 14.0.1 - scrolling is fluid
> Firefox 15.0b6 - scrolling is choppy
> 
> Can someone please try if they can reproduce this?

Scrolling looks a little bit choppy to me both on FF 14.0.1 and 15b6.
Comment 19 Paul Silaghi, QA [:pauly] 2012-08-23 06:46:17 PDT
Tested on Win 7 x64
Comment 20 alanjstr 2012-08-23 07:06:40 PDT
Is there anything that indicates which Flash version?  I have seen a performance downgrade from Flash 10.3 to 11.3 on multiple machines.
Comment 21 [:Cww] 2012-08-23 08:38:24 PDT
I was comparing 14 and 15 on the same time periods so there shouldn't be a difference in the flash version.
Comment 22 Ioana (away) 2012-08-23 09:05:23 PDT
I only met one performance issue I don't seem to reproduce on Firefox 14 nor Firefox 15 pre-beta 5. This issue is intermittent though, so I can't be sure of this.

I only reproduced it on Firefox 15 beta 6 on Ubuntu 12.04 64-bit:

STR:
1. Load http://www.imdb.com/trailers in the browser.
2. Start playing a video.
3. Click on the progress bar to skip forward in the video (it doesn't matter if the video got loaded to the point you skip to or not).
Actual Results: Firefox freezes for 5 to 20 seconds - intermittent issue.
Comment 23 Ioana (away) 2012-08-23 09:07:21 PDT
(In reply to Ioana Budnar [QA] from comment #22)
...
> I only reproduced it on Firefox 15 beta 6 on Ubuntu 12.04 64-bit:
...

Adobe Flash stopped support for Linux from Flash 11.2, so I was using Flash 11.2.
Comment 24 Ioana (away) 2012-08-23 09:56:04 PDT
Created attachment 654667 [details]
about:telemetry memory metrics

The about:telemetry data obtained with the followins steps on Windows 7 32-bit SP1 and Flash 11.4:
1. Open Firefox  14.0.1 
2. Install about:telemetry add-on
3. Log in to facebook and play 2 games (Bejeweled Blitz, The Sims Social)
4. Play 3 youtube videos
5. Open about:telemetry and observe memory results
6. Repeat steps 2-5 for Firefox 15b6.

There are differences between the results for Fx 14.0.1 and Fx 15 beta 6, but they should be interpreted by someone that knows more exactly what they mean.
Comment 25 (dormant account) 2012-08-23 10:34:58 PDT
10:22 <@khuey> taras: but if you're seeing memory regressions in 15, it's probably compartment-per-global fallout
10:23 < taras> khuey: so nothing that would be related to pageload speed
10:23 < taras> other than the usual more memory = more thrashing
10:24 <@khuey> not that I can think of
10:24 <@khuey> unless compartment creation is really slow or something

Sounds like the memory regression is likely not a factor in this, however it would be good to get metrics to confirm that slower pageload times are not strongly correlated with higher memory usage.
Would also be good to get an idea of how related cache perf is to slower pageload perf.
Comment 26 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-08-23 14:36:05 PDT
I have noticed frequent (but not constant) huge pauses and hangs that seem to be related to Flash 11.3.300 in Nightly on Windows 7. Killing the FlashPlayer process makes things much snappier for me, but since every page uses Flash, the problem comes just ends up occuring again after browsing for a while.
Comment 27 timbugzilla 2012-08-24 01:40:09 PDT
Hi Brian, I've noticed a lot of jank with Flash. You can access a profile at Bug 772763 - Opening plugins stream blocks the browser for 70ms per stream (2 seconds with multiple videos):

https://bugzilla.mozilla.org/show_bug.cgi?id=772763
Comment 28 Scoobidiver (away) 2012-08-24 05:24:01 PDT
(In reply to [:Cww] from comment #0)
> Running a statistical analysis of word frequencies in input, we have twice
> as much feedback mentioning slow|slowly|speed|forever in 15 relative to 14.
What do you mean by relative? Did you normalize the two stats by the number of inputs per version? Indeed, 14.0.1 has about 500 inputs per day while 15.0 has about 2300 inputs per day.
In addition, 77% of inputs are about issues in 14.0.1 (probably related to Flash) while only 61% in 15.0 Beta.
Comment 29 [:Cww] 2012-08-24 09:32:39 PDT
yes, I normalized on total amount of "issues" reported as well as checked against historical numbers. (This isn't my first rodeo, so to speak).
Comment 30 Ian Nartowicz 2012-09-21 12:56:36 PDT
I don't know if my issue is related or not, but I have seen a very specific performance regression between 14.0.1 and 15.0.1.  I have a loop which creates several hundred DOM elements in a box, and then adds the box to the DOM.  Prior to FF15. this would take a few ms for populate the box and around 100ms to add it to the DOM.  Starting with FF15 it takes around 100ms to populate the box and about the same to add it to the DOM.  By inlining a function call that creates each element, performance returned to pre-15 levels.

This is all tested on Linux.  The regression shows in 15.0.1, 16.0a1-3, and unfortunately later versions including nightly will not run at all for unrelated reasons.
Comment 31 Lawrence Mandel [:lmandel] (use needinfo) 2012-09-21 13:28:22 PDT
Ian - Yours sounds like a very specific issue that may or may not be related to this bug. Do you have a small, reproducible test case that you can attach to a new bug for your issue? Can you please file a new bug?
Comment 32 Ian Nartowicz 2012-09-22 14:28:55 PDT
Currently my testcase is embedded in a rather complex addon.  In looking to simplify it, I've discovered that the slowdown only occurs when the function called from the loop is in a javascript code module.  More specifically, it only occurs when a piece of DOM-related data is passed to the function.  Even more specifically, it only occurs when the DOM-related data is operated on, for example by setting an attribute.

The size of the slowdown is apparently not related to the quantity or size of the input parameters, nor to the amount of work performed on them.  Setting one attribute on one element produces the same effect as passing in several elements as well as a local document pointer, then performing several operations on them.
Comment 33 Charles Evans 2012-12-11 15:41:28 PST
Please pardon my slightly O/T example:
I can file a new bug if you prefer. 

Slowdown seems worse now in FFOX17 vs ffox15, 
but it only gets really bad at amazon.com.
Open 50 tabs and idle CPU use pegs at 100%
-> everything gets VERY slow.
JS compartments start at up to 6M/page,
(e.g. the lightning deals page)
growing overnight to about 25M/page avg. while idle,
always crashing when it hits 2.5G VM on 32bit debian linux.
(Wanted: an option to freeze all JS for all tabs but the viewed one)
Flash is not installed.
Comment 34 Scoobidiver (away) 2012-12-11 23:08:01 PST
(In reply to Charles Evans from comment #33)
> Slowdown seems worse now in FFOX17 vs ffox15, 
This bug is about Fx 15 vs Fx 14. In addition, it's a generic one. If after following steps in https://support.mozilla.org/kb/troubleshoot-and-diagnose-firefox-problems you still experience that issue, you can file a new bug.
Comment 35 Ioana (away) 2013-03-29 03:05:52 PDT
Removing the QAwanted keyword since QA already answered this request for help. Please re-add it if you need anything else related to this bug investigated.
Comment 36 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-04-01 10:27:13 PDT
At this point we may just want to resolve this WONTFIX (or WORKSFORME if input in this regard has died down).
Comment 37 Justin Dolske [:Dolske] 2013-04-01 12:26:50 PDT
Concur. This feels like a rather unactionable bug.

Note You need to log in before you can comment on or make changes to this bug.