Crash Report [@ __libc_android_abort | dlfree | free | libGLESv2_adreno200.so@0x6d9af ]

RESOLVED DUPLICATE of bug 766816

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED DUPLICATE of bug 766816
6 years ago
6 years ago

People

(Reporter: Paul Feher, Unassigned)

Tracking

({crash, reproducible})

15 Branch
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox15- affected)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-6838c7da-c78a-4bbd-afba-d607e2120822 .
============================================================= 
Frame 	Module 	Signature 	Source
0 	libc.so 	__libc_android_abort 	
1 	libc.so 	dlfree 	
2 	libc.so 	free 	
3 	libGLESv2_adreno200.so 	libGLESv2_adreno200.so@0x6d9af 	
4 	libGLESv2_adreno200.so 	libGLESv2_adreno200.so@0x617e5 	
5 	libGLESv2_adreno200.so 	libGLESv2_adreno200.so@0x640cf 	
6 	libEGL_adreno200.so 	libEGL_adreno200.so@0x1438e 	
7 	libEGL_adreno200.so 	libEGL_adreno200.so@0xedce 	
8 	libEGL_adreno200.so 	libEGL_adreno200.so@0x1438e 	
9 	libEGL_adreno200.so 	libEGL_adreno200.so@0x1438e 	
10 	libEGL_adreno200.so 	libEGL_adreno200.so@0xee56 	
11 	libEGL_adreno200.so 	libEGL_adreno200.so@0x1438e 	
12 	libEGL_adreno200.so 	libEGL_adreno200.so@0xef8a 	
13 	libgsl.so 	os_mutex_unlock 	
14 	libEGL_adreno200.so 	libEGL_adreno200.so@0xe85e 	
15 	libEGL_adreno200.so 	libEGL_adreno200.so@0x7746 	
16 	libEGL_adreno200.so 	libEGL_adreno200.so@0x1438e 	
17 	libEGL_adreno200.so 	libEGL_adreno200.so@0x10faa 	
18 	libEGL.so 	eglGetProcAddress 	
19 	libEGL_adreno200.so 	libEGL_adreno200.so@0x10fc6 	
20 	libEGL.so 	eglMakeCurrent 	
21 	libxul.so 	mozilla::gl::GLContextEGL::MakeCurrentImpl 	gfx/gl/GLLibraryEGL.h:174
22 	libxul.so 	mozilla::gl::GLContext::MakeCurrent 	GLContext.h:591
23 	libxul.so 	mozilla::gl::GLContextEGL::Init 	gfx/gl/GLContextProviderEGL.cpp:296
24 	libxul.so 	mozilla::gl::GLContextEGL::CreateEGLPBufferOffscreenContext 	gfx/gl/GLContextProviderEGL.cpp:2041
25 	libxul.so 	mozilla::gl::GLContextProviderEGL::CreateOffscreen 	gfx/gl/GLContextProviderEGL.cpp:2218
26 	libxul.so 	mozilla::WebGLContext::SetDimensions 	content/canvas/src/WebGLContext.cpp:503
27 	libxul.so 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:618
28 	libxul.so 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:539
29 	libxul.so 	nsIDOMHTMLCanvasElement_GetContext 	obj-firefox/js/xpconnect/src/dom_quickstubs.cpp:18062
30 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:395
31 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2515
32 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:266
33 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:329
34 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5549
35 	libxul.so 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:1899
36 	libxul.so 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:191
37 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:809
38 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:866
39 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:137
40 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:317
41 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:643
42 	libxul.so 	DocumentViewerImpl::LoadComplete 	layout/base/nsDocumentViewer.cpp:1023
43 	libxul.so 	nsDocShell::EndPageLoad 	docshell/base/nsDocShell.cpp:6239
44 	libxul.so 	nsDocShell::OnStateChange 	docshell/base/nsDocShell.cpp:6070
45 	libxul.so 	nsDocLoader::DoFireOnStateChange 	uriloader/base/nsDocLoader.cpp:1351
46 	libxul.so 	nsDocLoader::doStopDocumentLoad 	uriloader/base/nsDocLoader.cpp:931
47 	libxul.so 	nsDocLoader::DocLoaderIsEmpty 	uriloader/base/nsDocLoader.cpp:820
48 	libxul.so 	nsDocLoader::OnStopRequest 	uriloader/base/nsDocLoader.cpp:704
49 	libxul.so 	nsLoadGroup::RemoveRequest 	netwerk/base/src/nsLoadGroup.cpp:698
50 	libxul.so 	nsDocument::DoUnblockOnload 	content/base/src/nsDocument.cpp:7175
51 	libxul.so 	nsDocument::UnblockOnload 	content/base/src/nsDocument.cpp:7117
52 	libxul.so 	nsDocument::DispatchContentLoadedEvents 	content/base/src/nsDocument.cpp:4191
53 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:313
54 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
55 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:213
56 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
57 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
58 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
59 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
60 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:255
61 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3793
62 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3870
63 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3946
64 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:73
65 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	mozglue/android/APKOpen.cpp:972
66 	libdvm.so 	dvmPlatformInvoke 	
67 	libdvm.so 	dvmCallJNIMethod_general 	
68 	libdvm.so 	dvmResolveNativeMethod 	
69 	libdvm.so 	dvmAsmSisterStart 	
70 	libdvm.so 	dvmMterpStd 	
71 	libdvm.so 	dvmInterpret 	
72 	libdvm.so 	dvmCallMethodV 	
73 	libdvm.so 	dvmCallMethod 	
74 	libdvm.so 	dvmDetachCurrentThread 	
75 	libc.so 	__thread_entry 	
76 	libc.so 	pthread_create 	
77 		@0x475ff6

Steps to reproduce:
1. Load http://get.webgl.org/
(Reporter)

Comment 1

6 years ago
Firefox Native 15.0b6 build1 (2012-08-22)
Device: HTC Desire Z (Adreno 205)
OS: Android 2.3.3

Steps to reproduce:
1. Load http://get.webgl.org/
status-firefox15: --- → affected
tracking-firefox15: --- → ?

Comment 2

6 years ago
It's likely a dupe of bug 766816.
Does it happen in Nightly?
Component: General → Canvas: WebGL
Keywords: reproducible
Product: Firefox for Android → Core
Whiteboard: [native-crash]
Version: Firefox 15 → 15 Branch
Not seeing this in topcrashers and we're about to ship FF15 so won't track for 15 - please check Nightly/Aurora and nominate for tracking 16/17 if affected and not a dupe.
tracking-firefox15: ? → -
(Reporter)

Comment 4

6 years ago
WebGL is not supported for Adreno devices on Nightly 17.0a1 (2012-08-22) and Aurora 16.0a2 (2012-08-22).

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 766816
You need to log in before you can comment on or make changes to this bug.