Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Kyocera Echo - Crash on startup (Cannot load library: alloc_mem_region[889]: OOPS: 68 cannot map library 'libEGL_adreno200.so'. no vspace available)

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash, relnote})

Trunk
ARM
Android
crash, relnote
Points:
---

Firefox Tracking Flags

(firefox14 unaffected, firefox15+ disabled, firefox16 unaffected, firefox17 unaffected, fennec+)

Details

(Whiteboard: [native-crash][15.0b6][startupcrash], URL)

(Reporter)

Description

5 years ago
load_driver(/system/lib/egl/libEGL_adreno200.so): Cannot load library: alloc_mem_region[889]: OOPS: 68 cannot map library 'libEGL_adreno200.so'. no vspace available.

http://www.appthwack.com/public/4kxyti28dl/jobrun/470947
(Reporter)

Updated

5 years ago
Whiteboard: [native-crash] → [native-crash][15.0b6]
(Reporter)

Comment 1

5 years ago
Perhaps we want to block this device and relnote the incompatibility.

Updated

5 years ago
Whiteboard: [native-crash][15.0b6] → [native-crash][15.0b6][startupcrash]
This seems to be only the Kyocera Echo. Checked the HTC Desire which has the same GPU, Adreno 200.
The current Aurora and Nightly builds do not crash.
status-firefox16: --- → unaffected
status-firefox17: --- → unaffected
tracking-firefox15: --- → ?

Comment 4

5 years ago
Does Firefox 14(.0.1) crash on startup when using a Kyocera Echo?
(Reporter)

Comment 5

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #4)
> Does Firefox 14(.0.1) crash on startup when using a Kyocera Echo?

This run (http://www.appthwack.com/public/ZfzSJqr1Nd
) does not indicate so. Kevin can try his device in hand tomorrow.
(Reporter)

Updated

5 years ago
status-firefox14: --- → unaffected
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
let's rel note and block this phone in the market
Keywords: relnote

Comment 7

5 years ago
(In reply to Brad Lassey [:blassey] from comment #6)
> let's rel note and block this phone in the market

I agree, but we definitely need to figure out what's going on in case this may affect other devices. Blocking a single phone may not do the trick. Let's find the regressing bug.
tracking-firefox15: ? → +
Keywords: regressionwindow-wanted

Updated

5 years ago
Depends on: 785152

Updated

5 years ago
Blocks: 785152
No longer depends on: 785152
tracking-fennec: ? → +
Marking "disabled" since we did block the phone in  bug 785152 and noted it in release notes http://www.mozilla.org/en-US/mobile/15.0/releasenotes/
status-firefox15: affected → disabled
(Reporter)

Comment 9

5 years ago
QA triage note - will probably just let this ride out into 16 as it's fixed there
Works for me with the release of Fx 16 tomorrow.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.