Closed Bug 784790 Opened 9 years ago Closed 8 years ago

GCLI cookie command should use internal Cookie API rather than document.cookie

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

16 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: dangoor, Assigned: jwalker)

References

()

Details

Attachments

(1 file, 3 obsolete files)

STR:
1. go to http://www.mozilla.org/
2. cookie list (see WT_FPC cookie and possibly others)
3. cookie remove WT_FPC
4. cookie list

Expected: no WT_FPC cookie listed
Result: WT_FPC cookie lives on (at least in the list!)
This is half expected, because cookies are like that. Really we should be using the official cookie API.
Summary: [toolbar] [gcli] cookie remove command does not appear to remove the cookie → GCLI cookie command should use internal Cookie API rather than document.cookie
Target Milestone: --- → Future
There's lots of potential to be smarter if we're using the official API:

>> cookie list --on-domain google.com

(lists cookies from google.com whatever page you're currently on)

>> cookie edit WT_FPC some-value

(Alters the value of a cookie, maybe also set flags, e.g. HTTP_Only)
We could make use of a date type (see bug 773271) with the expires field.
Depends on: 773271
Assignee: nobody → mgoodwin
Blocks: 794413
I know Joe's hacking on the version of my code I gave him, I wanted somewhere to put my patch in the meantime.
No longer depends on: 773271
Attached patch v2 (cookie list output update) (obsolete) — Splinter Review
Added updates to 'cookie list' output.
Assignee: mgoodwin → jwalker
Attachment #665925 - Attachment is obsolete: true
New component triage. Filter on "Lobster Thermidor aux crevettes with a Mornay sauce"
Component: Developer Tools → Developer Tools: Graphic Commandline and Toolbar
No longer depends on: 831720
Assignee: jwalker → mratcliffe
OS: Mac OS X → All
Hardware: x86 → All
Assignee: mratcliffe → jwalker
Attached patch v3Splinter Review
Attachment #718957 - Attachment is obsolete: true
Attachment #728368 - Flags: review?(mratcliffe)
Comment on attachment 728368 [details] [diff] [review]
v3

Review of attachment 728368 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #728368 - Flags: review?(mratcliffe) → review+
https://hg.mozilla.org/mozilla-central/rev/d5cdec6efff9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Duplicate of this bug: 858907
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.