Editor charset encoding menu needs UE implementation

VERIFIED FIXED in M16

Status

()

Core
Internationalization
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: cata)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][PDT-])

(Reporter)

Description

18 years ago
Tested 6-09-10 Win32 build.

After you type some Japanese characters in the Editor and select menu File|Save to save the file,
the Japanese characters you typed in the file are missing.

Step of reproduce
1. Launch Apprunner
2. Select menu Tasks|Editor to open the Editor
3. Type Japanese character in the Editor
4. Select menu File|Save and save as a file
5. Open the file you saved in step #4 from Browser
You cannot see any Japanese characters in the page.

Updated

18 years ago
Assignee: ftang → nhotta
Blocks: 7228

Comment 1

18 years ago
Naoki, please handle this since you are the most knowledge person about Ender in
our group. Thanks.

Comment 2

18 years ago
I don't see that there is a charset menu in Editor yet.
I have been able to save Latin1 high-bit characters, however.
This seems to indicate that we are defaulting to Latin 1 in Editor.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M8

Comment 3

18 years ago
I am going to put charset menu for M8 (identical one as mail compose).
Then I will reassign to Ender group. Adding Steve Clark to cc.

Comment 4

18 years ago
Correction to my last comment. Plan to make the menu identical to browser not
mail compose.

Updated

18 years ago
Assignee: nhotta → buster
Status: ASSIGNED → NEW

Comment 5

18 years ago
I added a charset menu for HTML editor. This is UI only change and the menu is
not functioning.
Please reassign this to someone in Ender.

Comment 6

18 years ago
Could somebody in I18N please explain what this menu is supposed to do?
I can guess that it is supposed to call nsIDocument::SetDocumentCharacterSet,
but I don't know how we are supposed to know what string to pass in as the char
set.

Updated

18 years ago
Assignee: buster → akkana

Comment 7

18 years ago
After some research, I think I understand this issue better.  I think the editor
needs to do 2 things in response to a Character Set menu selection:
1. create/change a META tag in the head to reflect the new character set
2. store the character set choice internally, so on output XIF can choose the
correct converter.
The interface on nsIDocument is irrelevant for our purposes.  It causes a
re-parse of the document which is something we DON'T want while editing.
Assigned to Akkana.

Comment 8

18 years ago
Move XIF/I18n bugs to M9; they're dependant on stubs which I18n is trying to get
in for M8.

Updated

18 years ago
Summary: Editor-Save function does not support I18n characters → Editor charset encoding menu needs implementation
Target Milestone: M9 → M15

Comment 9

18 years ago
Changing summary; it was misleading, this isn't an output/XIF issue, it's an
issue of implementing the charset menu.  Not clear who owns this; it doesn't
seem to appear on our editor schedule.

Comment 10

18 years ago
A spec for implementing this is coming soon.

Comment 11

18 years ago
I think fixing this bug (really a feature request) requires 2 things:
1. code to create the meta tag properly (finding/creating <HEAD>, scanning
<META> tags for the charset attribute, inserting/replacing the charset attribute
in the right META tag)
2. storing information in the editor about the current charset, so that
information can be passed along to I18N converters on output.
Akkana, I will add the editor portions of this to the editor schedule.

Comment 12

18 years ago
For clarification, what I meant by "spec" is a UI spec. Engineering
details will be left to engineer assiged and I18n consultants.

Updated

18 years ago
Assignee: akkana → momoi

Comment 13

18 years ago
Reassigning to momoi, since we can't do anything about this until we know what
we're supposed to do.  Please reassign back to the editor group when the spec is
ready.  Also adding brade to cc list.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 14

18 years ago
Working on this. It will be a few more days. Accepting it.

Updated

18 years ago
No longer blocks: 7849
No longer depends on: 7849

Updated

18 years ago
Depends on: 11687

Updated

18 years ago
Summary: Editor charset encoding menu needs implementation → Editor charset encoding menu needs UE implementation

Comment 15

18 years ago
Basic encoding menu is now in via Bug 11687.
We'll keep this bug open to implement other UE specs of
this menu item.

Updated

18 years ago
Assignee: momoi → tague
Status: ASSIGNED → NEW
Target Milestone: M15 → M11

Comment 16

18 years ago
We now have a working proposal for implementing this menu here:

http://rocknroll/users/momoi/publish/seamonkey/5_0intleditorui.html

Re-assigning to tague with M11 milestone.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 17

18 years ago
The menu is there, but it's not changing the meta tag in the document to reflect
the changed charset.  This has caused the problems described in bug 12085.

Comment 18

18 years ago
*** Bug 12085 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: tague → cata
Status: ASSIGNED → NEW

Comment 19

18 years ago
cata, I will let you handle "charset" menu work, including this. Tague and Naoki, please help cata. Thanks
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Blocks: 18951

Updated

18 years ago
Blocks: 17791
(Assignee)

Updated

18 years ago
Target Milestone: M12 → M13
(Assignee)

Updated

18 years ago
Blocks: 20761
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M14

Comment 20

18 years ago
change platform to ALL
Hardware: PC → All

Comment 21

18 years ago
Change OS to ALL
OS: Windows NT → All
(Reporter)

Updated

18 years ago
Keywords: beta1

Comment 22

18 years ago
PDT - Frank - please explain further why this ought to be +
Whiteboard: [PDT-]

Comment 23

18 years ago
Without it, you cannot create any HTML in Japanese encoding.
(Reporter)

Comment 24

18 years ago
Changed QA contact to amasri@netscape.com.
QA Contact: teruko → amasri

Updated

18 years ago
Target Milestone: M14 → M15
(Assignee)

Comment 25

17 years ago
Beta2 feature.
Target Milestone: M15 → M16

Updated

17 years ago
Keywords: beta2

Updated

17 years ago
Keywords: nsbeta2

Updated

17 years ago
Keywords: beta2

Comment 26

17 years ago
Putting on [nsbeta2+] radar for beta2 fix.

teruko, msanz thinks this is fixed..can you re-test.
QA Contact: amasri → teruko
Whiteboard: [PDT-] → [nsbeta2+][PDT-]
(Assignee)

Comment 27

17 years ago
After discussing with Kat: 
This bug is no longer pertinent, it has been replaced with a bunch of bugs 
describing the work to be done in better details.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 28

17 years ago
Agreed. This original request now has all the pieces filed in separate bugs broken down into 
engineering tasks.
 
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 18951
You need to log in before you can comment on or make changes to this bug.