"Assertion failure: uint32_t(startOffset) <= startParent->Length() && uint32_t(endOffset) <= endParent->Length()"

RESOLVED DUPLICATE of bug 785720

Status

()

RESOLVED DUPLICATE of bug 785720
6 years ago
6 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86_64
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 654491 [details]
testcase

Assertion failure: uint32_t(startOffset) <= startParent->Length() && uint32_t(endOffset) <= endParent->Length(), at content/base/src/nsContentIterator.cpp:1203

This assertion was added in bug 767169, so maybe it's related to bug 772387.  But this isn't the first problem caused by MathML-layout's habit of modifying the DOM.
(Reporter)

Comment 1

6 years ago
Created attachment 654492 [details]
stack trace
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785720
You need to log in before you can comment on or make changes to this bug.