heap-unclassified close to 50% after hibernation

RESOLVED DUPLICATE of bug 750048
(NeedInfo fromanyone)

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 750048
5 years ago
5 years ago

People

(Reporter: julian.force, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug, {regression})

15 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Memshrink:P3][regression:ff15])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120814224555

Steps to reproduce:

Using firefox 15 without a restart for 3 work days (hibernating PC overnight).
Mail, twitter, msdn, ...


Actual results:

1,143.28 MB (100.0%) -- explicit
├────527.28 MB (46.12%) ── heap-unclassified
├────442.52 MB (38.71%) -- js
│    ├──328.34 MB (28.72%) ++ (927 tiny)
│    ├───30.14 MB (02.64%) ── gc-heap-decommitted
│    ├───19.00 MB (01.66%) ++ compartment(https://twitter.com/)
│    ├───18.83 MB (01.65%) -- compartment(atoms)
│    │   ├──13.17 MB (01.15%) ── string-chars
│    │   └───5.66 MB (00.50%) ++ (2 tiny)
│    ├───16.82 MB (01.47%) ++ compartment(https://mail.google.com/mail/u/0/)
│    ├───15.77 MB (01.38%) ++ compartment(https://www.google.com/reader/view/)
│    └───13.62 MB (01.19%) ++ compartment(https://mail.google.com/mail/u/1/)
├─────61.91 MB (05.41%) -- window-objects
│     ├──48.74 MB (04.26%) ++ (17 tiny)
│     └──13.17 MB (01.15%) ++ top(https://mail.google.com/mail/u/0/?ui=2&shva=1#inbox, id=12)/active
├─────45.78 MB (04.00%) -- images
│     ├──45.08 MB (03.94%) -- content
│     │  ├──43.63 MB (03.82%) -- used
│     │  │  ├──31.69 MB (02.77%) ── raw
│     │  │  └──11.95 MB (01.04%) ++ (2 tiny)
│     │  └───1.45 MB (00.13%) ++ unused
│     └───0.70 MB (00.06%) ++ chrome
├─────22.95 MB (02.01%) -- storage
│     ├──21.40 MB (01.87%) ++ sqlite
│     └───1.56 MB (00.14%) ── prefixset/all
├─────17.32 MB (01.51%) ── network-memory-cache
├─────15.66 MB (01.37%) -- gfx
│     ├──14.46 MB (01.26%) ── font-shaped-words
│     └───1.20 MB (00.10%) ++ (3 tiny)
└──────9.86 MB (00.86%) ++ (7 tiny)


Expected results:

Before firefox 15, heap-unclassified stayed below 25% with the same habits
Duplicate of this bug: 784990

Updated

5 years ago
Whiteboard: [Memshrink]

Comment 2

5 years ago
Look at the line where it says 328.34MB : there are 927 small items, but none can be seen. Then it's difficult to see where the leak could be.
(Reporter)

Comment 3

5 years ago
Unfotunately i have wiped the about:memory file i send previously and have just restarted to install the new beta.
I will attach a file as soon as I appreciate the issue again.

Comment 4

5 years ago
Yes, when you want to save a memory log, type about:memory?verbose to have a complete log.
(Reporter)

Comment 5

5 years ago
Created attachment 655536 [details]
verbose About:memory log
(Reporter)

Comment 6

5 years ago
From first report, I have updated to the latest beta channel version.

In about:memory, hap-unclassified reported aroun 35%. When i switched to about:memory?verbose it rose to near 45%.

As estated before, I experienced this with the introduction of 15 branch.

Comment 7

5 years ago
Created attachment 655554 [details]
about:memory log of reporter (as .txt)

I attached your log as txt, easier to open. :)
If this first started with Firefox 15 (ie. it does not happen with Firefox 14.0.1) then I would suspect this to be related to a change (or series of changes) during the Firefox 15 Nightly phase. Can you please test some of the Firefox 15 nightlies to see if this regressed at some point?

You'll find our Firefox 15 nightlies on the FTP server between 2012-04-25 and 2012-06-04.
ftp://ftp.mozilla.org/pub/firefox/nightly/

Thanks
Component: Untriaged → General
Summary: heap-unclassified close to 50% → heap-unclassified close to 50% after hibernation
(Reporter)

Comment 9

5 years ago
Created attachment 657228 [details]
about_memory using 15.0a1 (2012-05-15) as txt

Percentage isn't quite as high due to greater memory consumption.

Should I try an older or maybe a newer version? An older one, don't I?
Unfortunately this kind of problem is really hard to track down.  If you can give us more precise steps to reproduce.  Also, if you find that memory consumption somehow increases suddenly after waking up from hibernation, that would be good to know.  In the absence of either of these, we won't be able to do much.
Blocks: 563700
Whiteboard: [Memshrink] → [Memshrink:P3]
(Reporter)

Comment 11

5 years ago
Understood.

I'll try to reproduce the bug in last beta.
> Look at the line where it says 328.34MB : there are 927 small items, but
> none can be seen. Then it's difficult to see where the leak could be.

Oh, you can click on a "++ (N tiny)" line in about:memory and the sub-tree will expand.  You can also click on an expanded sub-tree to collapse it.  Or you can view about:memory?verbose to see the whole tree fully expanded.

I suspect the info from the additional 927 small items won't tell us much that is interesting in this case.
(Reporter)

Comment 13

5 years ago
I've been avoiding Google Reader in Firefox since the last report.

Total use of memory has shrinked and heap-unclasified usage notably improved:

667.77 MB (100.0%) -- explicit
├──331.08 MB (49.58%) ++ js
├──142.28 MB (21.31%) ── heap-unclassified
├───85.92 MB (12.87%) -- window-objects
│   ├──30.84 MB (04.62%) ++ (21 tiny)
│   ├──20.49 MB (03.07%) -- top(https://twitter.com/#!/, id=20)/active
│   │  ├──20.20 MB (03.02%) -- window(https://twitter.com/#!/)
│   │  │  ├──11.50 MB (01.72%) -- layout
│   │  │  │  ├───8.63 MB (01.29%) ── arenas
│   │  │  │  └───2.88 MB (00.43%) ++ (3 tiny)
│   │  │  ├───7.66 MB (01.15%) ── dom [2]
│   │  │  └───1.03 MB (00.15%) ── style-sheets
│   │  └───0.29 MB (00.04%) ++ (3 tiny)
│   ├──13.51 MB (02.02%) ++ top(https://mail.google.com/mail/u/1/?ui=2&shva=1#search/bug/13973479ca5d8bdd, id=14)/active
│   ├──13.24 MB (01.98%) -- top(https://mail.google.com/mail/u/0/?ui=2&shva=1#inbox, id=16)/active
│   │  ├───8.07 MB (01.21%) ++ window(https://mail.google.com/mail/u/0/?ui=2&view=bsp&ver=ohhl4rw8mbn4)
│   │  └───5.17 MB (00.77%) ++ (4 tiny)
│   └───7.84 MB (01.17%) -- top(https://www.facebook.com/, id=18)/active
│       ├──7.72 MB (01.16%) ++ window(https://www.facebook.com/)
│       └──0.12 MB (00.02%) ++ window(https://www.facebook.com)
├───40.34 MB (06.04%) -- dom/workers(repl.it)/worker(http://repl.it/jsrepl/sandbox.js, 0x21b5480021b54800)
│   ├──32.23 MB (04.83%) -- compartment(Web Worker)
│   │  ├──24.29 MB (03.64%) -- objects
│   │  │  ├──24.11 MB (03.61%) ── elements
│   │  │  └───0.19 MB (00.03%) ── slots
│   │  └───7.93 MB (01.19%) ++ (5 tiny)
│   └───8.11 MB (01.22%) ++ (6 tiny)
├───23.29 MB (03.49%) -- storage
│   ├──21.70 MB (03.25%) -- sqlite
│   │  ├──11.25 MB (01.69%) -- places.sqlite
│   │  │  ├──10.80 MB (01.62%) ── cache-used [4]
│   │  │  └───0.45 MB (00.07%) ++ (2 tiny)
│   │  └──10.45 MB (01.56%) ++ (12 tiny)
│   └───1.59 MB (00.24%) ── prefixset/all
├───19.55 MB (02.93%) -- images
│   ├──18.70 MB (02.80%) -- content
│   │  ├──18.70 MB (02.80%) -- used
│   │  │  ├──17.92 MB (02.68%) ── raw
│   │  │  └───0.78 MB (00.12%) ++ (2 tiny)
│   │  └───0.00 MB (00.00%) ++ unused
│   └───0.85 MB (00.13%) ++ chrome
├───12.77 MB (01.91%) ++ (9 tiny)
└───12.54 MB (01.88%) ── network-memory-cache

I don't know if its related to Reader directly or it has to do with the open/close of loads of tabs related to Reader usage.

I can't tell if it has anything to do with hibernation (why that title modification?)

Comment 14

5 years ago
There is bug 750048 about Google Reader and memory leaking.

Comment 15

5 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> If this first started with Firefox 15 (ie. it does not happen with Firefox
> 14.0.1) then I would suspect this to be related to a change (or series of
> changes) during the Firefox 15 Nightly phase. Can you please test some of
> the Firefox 15 nightlies to see if this regressed at some point?
> 
> You'll find our Firefox 15 nightlies on the FTP server between 2012-04-25
> and 2012-06-04.
> ftp://ftp.mozilla.org/pub/firefox/nightly/
> 
> Thanks
Flags: needinfo?(julian.force)
Keywords: regression
Whiteboard: [Memshrink:P3] → [Memshrink:P3][regression:ff15]
(Reporter)

Comment 16

5 years ago
I think it's related to/duplicate of bug 750048

I began using chrome to read GReader and the issue vanished.
Flags: needinfo?(julian.force)

Comment 17

5 years ago
Feel free to reopen it if the issue is back w/o GG Reader.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 750048
You need to log in before you can comment on or make changes to this bug.