The icon to activate invisible plugins with plugins.click_to_play=true is hard to notice

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Mikko Rantalainen, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120714012003

Steps to reproduce:

teps to reproduce:
1. Run Firefox nightly version 17.0a1 (2012-08-22) [Ubuntu 10.04 LTS 64 bit]
2. Open about:config and set plugins.click_to_play to true (see bug 711552)
3. Open https://ebanking.sampopankki.fi/html/index.html?site=SBNBEN&secsystem=E2 (Login page for the internet banking service for SampoPankki which is a Finnish subdiary of Danske Bank of Danmark)


Actual results:

The page stays at "Starting Java..." state forever.

(The page requires Java plugin to be enabled and as a result of click_to_play I get next to invisible lego brick in front of the URL bar to notify me that page requires plugins to work correctly. If I click the lego brick, I get option to activate plugins and the page starts to work.)


Expected results:

The current behavior is okay except the fact that the lego brick is next to impossible to notice (the brick is white brick with light grey border on white background and it appears at the same moment the whole page appears so there's practically no possibility to see it unless the user is expected to know that the brick will appear at the start of the address bar in case of plugin activation is required).

I'd suggest that the lego brick were colored bright yellow or red to make it stand out. Also, Google chrome uses the end of the URL bar for notifications such as this and it's better position because that area of the address bar is usually white and any addition to that area is easier to notice.
(Reporter)

Updated

5 years ago
Depends on: 746888
Version: 14 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 738698

Comment 1

5 years ago
Created attachment 654662 [details]
Click-to-play message under the blue brick

Maybe Firefox should display automatically the dialog box about the click-to-play feature (that appears only when the user click on the blue brick) when the user is connecting to the website for the 1st time.
The same as registering a password on a website for the 1st time.

Comment 2

5 years ago
Tanvi, maybe this is a good topic to discuss with our UX friends ? :)
OS: Linux → All
Hardware: x86_64 → All
Depends on: 810082
No longer depends on: 746888
Component: Untriaged → General

Comment 3

5 years ago
It "breaks" all invisible plugins. For example with Citrix Reciever, nothing happens and you can't notice any notification.
The UI for click-to-play is currently getting a redesign, with the missing discoverability of this for hidden plugins being one of the concerns.

Progress and discussions for that redesign should be on dev.apps.firefox.
Isn't this fixed by now?

* open https://ebanking.sampopankki.fi/html/index.html?site=SBNBEN&secsystem=E2
* I get a notification bar asking to run Java
* if yes, CtP doorhanger appears givening the choices of "allow now" and "allow and remember"
Yes, this is fixed by bug 932854 now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.