Last Comment Bug 785089 - "Assertion failure: pn_type < PNK_LIMIT,"
: "Assertion failure: pn_type < PNK_LIMIT,"
Status: RESOLVED FIXED
[jsbugmon:update]
: assertion, regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- critical (vote)
: mozilla17
Assigned To: u443197
: general
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: jsfunfuzz 433529
  Show dependency treegraph
 
Reported: 2012-08-23 08:27 PDT by Gary Kwong [:gkw] [:nth10sd]
Modified: 2013-01-19 14:03 PST (History)
5 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (4.92 KB, text/plain)
2012-08-23 08:27 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details
patch (4.76 KB, patch)
2012-08-23 09:59 PDT, u443197
jimb: review+
Details | Diff | Splinter Review

Description Gary Kwong [:gkw] [:nth10sd] 2012-08-23 08:27:54 PDT
Created attachment 654629 [details]
stack

odeURIL:(function(){})

asserts js debug shell on m-c changeset 198ca6edd0ae without any CLI arguments at Assertion failure: pn_type < PNK_LIMIT,

Due to skipped revisions, the first bad revision could be any of:
changeset:   103113:d7568555261c
user:        Alex Crichton
date:        Sat Aug 18 21:33:20 2012 -0700
summary:     Bug 433529: Part 1 - Statically resolve names for anonymous functions. r=jimb

changeset:   103114:4ebcfba34c38
user:        Alex Crichton
date:        Sat Aug 18 21:37:09 2012 -0700
summary:     Bug 433529: Part 2 - Add a displayAtom to JSFunction to store resolved names. r=jimb

(setting bisect in JSBugMon to reconfirm this bisection result)
Comment 1 Christian Holler (:decoder) 2012-08-23 09:06:08 PDT
JSBugMon: Bisection requested, result:
Due to skipped revisions, the first bad revision could be any of:
changeset:   103113:d7568555261c
user:        Alex Crichton
date:        Sat Aug 18 21:33:20 2012 -0700
summary:     Bug 433529: Part 1 - Statically resolve names for anonymous functions. r=jimb

changeset:   103114:4ebcfba34c38
user:        Alex Crichton
date:        Sat Aug 18 21:37:09 2012 -0700
summary:     Bug 433529: Part 2 - Add a displayAtom to JSFunction to store resolved names. r=jimb
Comment 2 u443197 2012-08-23 09:59:37 PDT
Created attachment 654673 [details] [diff] [review]
patch

This is mostly the extra additions you already had in bug 433529 Jim, although tweaked slightly to just skip PNK_COLON for labels because there won't be an assignment after that.
Comment 3 Jim Blandy :jimb 2012-08-23 10:32:09 PDT
Comment on attachment 654673 [details] [diff] [review]
patch

Review of attachment 654673 [details] [diff] [review]:
-----------------------------------------------------------------

Seems familiar, somehow. Thanks for the quick turnaround!
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-08-23 19:19:11 PDT
https://hg.mozilla.org/mozilla-central/rev/fcbf82dee1db
Comment 6 Christian Holler (:decoder) 2013-01-19 14:03:53 PST
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/efaf8960a929

Note You need to log in before you can comment on or make changes to this bug.