Closed Bug 785183 Opened 10 years ago Closed 9 years ago

Make sure re-review flagging reason is visible for apps in re-review queue.

Categories

(Marketplace Graveyard :: Reviewer Tools, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: krupa.mozbugs, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image screenshot
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/reviewers/apps/review/remember-the-milkfrom the re-review queue
2. Scroll to the App History section

expected behavior:
The reason the app has been flagged for re-review is listed

observed behavior:
Many apps in the re-review queue are missing this information.
Blocks: 766199
Summary: Check why some apps in the re-reveiw queue are missing the reason they have been flagged → Check why some apps in the re-review queue are missing the reason they have been flagged
The reason is there but it gets added to the approved 'version' so its on the third page.  

https://marketplace-dev.allizom.org/reviewers/apps/review/remember-the-milk?page=3#history

(Its got so many extra versions due to the over-active cron job that was running for a few weeks in May/June).

Solution would either be to fix the re-review entries so they always add to the latest version or to run something to delete the extra versions on the affected Apps.  My preference would be on the latter, if it could be done safely, though the former may be work needed for the packaged apps work anyway.
Summary: Check why some apps in the re-review queue are missing the reason they have been flagged → Make sure re-review flagging reason is visible for apps in re-review queue.
(In reply to Andrew Williamson [:eviljeff] from comment #1)
> Solution would either be to fix the re-review entries so they always add to
> the latest version

FYI: This is already happening, with a minor correction... it's logging against the "current version", which is the latest version whose file status is PUBLIC. Since the other versions there are listed as "DISABLED", the current version in this case happened to be a version hidden on page 3.
Blocks: 782711
No longer blocks: 766199
this isn't an issue any more as hosted apps only have one version and Rob flattened the review history for the kind of apps this bug was affecting a few months ago.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.