Last Comment Bug 785190 - Plugin preview overlay shows click-to-play icon when preview is present
: Plugin preview overlay shows click-to-play icon when preview is present
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Yury Delendik (:yury)
:
Mentors:
Depends on: 776208
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 12:38 PDT by Yury Delendik (:yury)
Modified: 2012-08-24 16:36 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
adds canActivatePlugin check to reshowClickToPlayNotification (1.14 KB, patch)
2012-08-23 12:38 PDT, Yury Delendik (:yury)
jaws: review+
dkeeler: feedback+
Details | Diff | Splinter Review
patch for checkin (1.22 KB, patch)
2012-08-23 15:05 PDT, Yury Delendik (:yury)
no flags Details | Diff | Splinter Review

Description Yury Delendik (:yury) 2012-08-23 12:38:40 PDT
Created attachment 654743 [details] [diff] [review]
adds canActivatePlugin check to reshowClickToPlayNotification

Per bug 776208 comment 61:

(In reply to David Keeler from comment #59)
> Comment on attachment 654628 [details] [diff] [review] [diff] [review]
> Plugin overlay API
> 
> Review of attachment 654628 [details] [diff] [review] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/base/content/browser-plugins.js
> @@ +198,5 @@
> >      let cwu = aContentWindow.QueryInterface(Ci.nsIInterfaceRequestor)
> >                              .getInterface(Ci.nsIDOMWindowUtils);
> >      let haveUnplayedPlugins = cwu.plugins.some(function(plugin) {
> >        let objLoadingContent = plugin.QueryInterface(Ci.nsIObjectLoadingContent);
> > +      return (plugin != aPlugin && gPluginHandler.canActivatePlugin(objLoadingContent));
> 
> Looks like we still need a similar check in reshowClickToPlayNotification

Yeah, that might case to show an icon on desktop when preview exists and click-to-play is on. 

> and _removeClickToPlayOverlays.

Not really necessary -- the preview does not use mainBox (it's hidden in this mode).
Comment 1 David Keeler [:keeler] (use needinfo?) 2012-08-23 12:59:54 PDT
Comment on attachment 654743 [details] [diff] [review]
adds canActivatePlugin check to reshowClickToPlayNotification

Review of attachment 654743 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. I'm sure you could just add this in to the patch you're getting ready to land in bug 776208 and carry over the r+s. I can't r+, so I'll just mark this feedback+.
Comment 2 Yury Delendik (:yury) 2012-08-23 15:05:04 PDT
Created attachment 654805 [details] [diff] [review]
patch for checkin
Comment 3 Yury Delendik (:yury) 2012-08-23 18:22:25 PDT
https://tbpl.mozilla.org/?tree=Try&rev=5c8281cb3918
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-24 13:22:48 PDT
Green on Try. Sorry for the obscenely long delay.
https://tbpl.mozilla.org/?tree=Try&rev=5c8281cb3918

https://hg.mozilla.org/integration/mozilla-inbound/rev/b3c861bd1e2f
Comment 5 Matt Brubeck (:mbrubeck) 2012-08-24 16:07:36 PDT
Sorry, I had to back this out because it depends on bug 776208 which was backed out:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7058cad952ca
Comment 6 Yury Delendik (:yury) 2012-08-24 16:36:11 PDT
The patch added to/combined with the bug 776208 Plugin overlay API patch

Note You need to log in before you can comment on or make changes to this bug.