duplicate headers for mail moved offline when online

VERIFIED FIXED

Status

defect
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: dyp, Assigned: Bienvenu)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

18 years ago
Using build 2001043004

Did some housecleaning with e-mail while offline, moving mail from inbox to
various folders.  After reconnecting, I now have duplicate headers in the targer
folder.  The one I moved over does not display the text body but the duplicate
behaves normally.

Updated

18 years ago
QA Contact: esther → gchan

Comment 1

18 years ago
Using build 2001043004 (though came from a folder labeled
2001-04-30-09-trunk/) on Win NT 4.0.

Trying to follow the steps to reproduce the bug, i was not
quite successful. Wasn't sure whether you are moving 'downloaded
mesgs [in italic]' or reg mesgs while in offline mode.
I tried moving both types while offline. I could reproduce the
bug but not every time. And dupes only happen with 'downloaded
mesgs [in italic]'. So I don't have any steps to reproduce.

Did notice these problems:
- 'Get Selected Messages' does not work if you select one message.
  works only if you select 2 or more.
- Once you have used 'Get Selected Messages', you are able to
  read the downloaded mesg in online or offline mode. But when
  you move that mesg to another folder while in offline mode.
  You no longer can read the body of the text whether online or
  offline mode.

I can create 2 new bugs if needed?

But maybe this bug is invalid since the front end of 'Get Selected
Messages' hasn't landed yet?


Reporter

Comment 2

18 years ago
Definitely experienced this with the downloaded (italic) mail.  I also
discovered the other problems Mr. Chan discovered.  Off-line mode has been the
most painful experience for me with N6.x.
Assignee

Comment 3

18 years ago
are all the folders you moved messages to imap folders?

What other problems have you had? This is the only bug you've seemed to file.
Reporter

Comment 4

18 years ago
I was referrring to other problems that gchan@netscape.com discovered.

Comment 5

18 years ago
When I was trying to reproduce the problem, I was using IMAP with
the "move to trash folder" deletion model.

Comment 6

18 years ago
tried opening the same mail account in 4.77 with the same settings. I don't
see any of the duplicate messages. But when I open it in 6.5,
I still see some of my duplicated 'downloaded' messages (in fact
a couple more dupes have appeared but I still don't know how
to replicate the problem)

Could it be a refresh problem in 6.5? 


Assignee

Comment 7

18 years ago
My guess is that it's trying to playback the offline operation more than once,
and resulting in duplicates. It seems as if it's not removing the offline
operation after performing it. I'll look into it.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Assignee

Comment 8

18 years ago
I can't reproduce the basic problem here - I'm not seeing any duplicate headers.
 I'll try some more later. Please file a bug for Get Selected Messages not
working when only one message is selected (the front end for get selected
messages has landed - what you see is what it is). Re the offline message body
not moving when you move a message offline, you can file a bug for that too -
I'm not sure I'll get to that - can't remember if 4.x dealt with that - I think
it did, however.

Comment 9

18 years ago
quick note: using 2001-05-03-10-trunk/ build on WinNT 4.0, I am
no longer seeing the duplicate headers/messages in my folders.
Looks like it is fixed? Do we change the status of this bug?

Still having problems reading the downloaded message once it's
moved from the inbox to another folder.

And yes Daivd, in 4.x if you move a downloaded message (while offline)
from the inbox to another folder, you are able to read the header
and body.
Assignee

Comment 10

18 years ago
David, are you still seeing this problem, and again, are you moving the message
to a local folder or another imap folder?
Keywords: nsbeta1
Reporter

Comment 11

18 years ago
Using build #2001043004, I'm still seeing this problem.  I've put pretty
diligent about using IMAP and this problem is from moving from IMAP Inbox to
another IMAP mailbox.
Assignee

Comment 12

18 years ago
I've managed to recreate this - to do so, I had to do the offline move, shutdown
the app, restart online, select the source folder for the move, then the dest
folder. Then, I see the dup. What's happening is that when we copy the hdr
offline, we create a hdr in the destination folder, but we don't know what its
UID is going to be, so we create a fake one. Then, when we open the dest folder
offline, we're downloading the actual msg with the correct uid, adding a header
for it, but not removing the fake header. I'm not sure why I had to shutdown in
order to see this problem, or why we're not cleaning up the fake header. 
Assignee

Comment 14

18 years ago
the problem was that we were deleting the offline op before getting the message
key, but in the new world order, deleting the offline op clears out all the row
columns, including the message key one. So I just rearranged the code. Also
fixed a warning, and turned on the code to be able to stop offline sync.
Assignee

Comment 16

18 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
adding trix to cc.  Please verify for gchan.

Comment 18

18 years ago
verified on:
linux build # 2001060506
win32 build # 2001060409
macos build # 2001060408
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
Clarifying tested branch builds but since fix
landed before branching there is no need to 
test trunk.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.