Last Comment Bug 785256 - Social button compartments pile up for long lived Google Reader tabs
: Social button compartments pile up for long lived Google Reader tabs
Status: RESOLVED DUPLICATE of bug 750048
[MemShrink]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 16:02 PDT by Lisa Brewster [:adora]
Modified: 2012-09-12 04:27 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Lisa Brewster [:adora] 2012-08-23 16:02:53 PDT
I'm experiencing excessive CPU and ram usage on OS X on a regular basis.  At the time About:memory was captured, FF was using 5gb ram and 105% cpu. (overachiever!)

Machine is a 2012 Macbook Air w/2GHz Intel Core i7 and 8gb ram running Mountain Lion.

About:memory?verbose - https://gist.github.com/a39152fc0be086729ace
About:support - https://gist.github.com/0a16e2e403e79d4bd10b
Comment 1 Kris Maglione [:kmag] 2012-08-23 16:12:42 PDT
The two things that stand out in the about:memory dump are the huge heap-unclassified (5GB/7.4GB) and the huge number of zombie compartments.

I tried to reproduce this with most of her add-ons installed, and it's not especially easy to reproduce the zombie compartment issue. It seems to only happen with certain sites. I'll try to figure out what add-on is causing that when I can figure out how to reliably trigger it, though it may not matter after 15 is released. The heap-unclassified issue apparently takes some time to manifest.
Comment 2 Nicholas Nethercote [:njn] 2012-09-04 16:24:10 PDT
Lisa, if you can narrow it down to a single add-on, that would be very helpful.
Comment 3 Kris Maglione [:kmag] 2012-09-04 17:58:56 PDT
So, the crazy number of like button compartments seem to be coming from Google Reader. I get them without any add-ons installed, and they go away when the tab is closed. That might be enough to explain everything, but 1Password is a Jetpack add-on, so it's possible that bug 780391 is also coming into play here and we're leaking subframes until the Reader tab is closed, in which case we need to retriage that bug.
Comment 4 Nicholas Nethercote [:njn] 2012-09-04 19:40:57 PDT
Also, it would be interesting to know if you are getting any messages in the error console that say "TypeError: can't access dead object".
Comment 5 Kris Maglione [:kmag] 2012-09-05 12:57:43 PDT
Ok, so these compartments seem to pile up on Google Reader whenever a pane is refreshed with or without 1Password. However, with 1Password, we seem to be getting 3 content script sandboxes for every one of those compartments...

Moving to Core > General and opening up for retriage, since this doesn't seem to be mainly an add-on issue. It might be a good idea to open another bug for the vast number of content compartments created by 1Password.
Comment 6 Andrew McCreight [:mccr8] 2012-09-05 13:07:03 PDT
Thanks for the analysis, Kris!  That kind of sounds like a dupe of bug 750048.
Comment 7 Kris Maglione [:kmag] 2012-09-11 15:47:02 PDT
Agreed, it seems like a dup. I'm not sure if the heap unclassified issue is related, though. We can reopen if that seems to remain when bug 750048 is fixed.

*** This bug has been marked as a duplicate of bug 750048 ***

Note You need to log in before you can comment on or make changes to this bug.