Closed Bug 785343 Opened 7 years ago Closed 7 years ago

Text in select/option elements affect the scoring

Categories

(Firefox for Android :: Reader View, defect, P2)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox16 --- verified
firefox17 --- verified
firefox18 --- verified

People

(Reporter: lucasr, Assigned: lucasr)

Details

Attachments

(1 file)

Pages like http://money.cnn.com/gallery/real_estate/2012/08/20/best-places-top-earning-towns.moneymag?hpt=hp_c2 and http://edition.cnn.com/WORLD/ have select elements with tons of options in them. The DIV containing this form is winning as best candidate because of this. We should penalize or ignore form elements when counting how content-ey an element is.
Attachment #654983 - Flags: review? → review?(mark.finkle)
Attachment #654983 - Flags: review?(mark.finkle) → review+
Comment on attachment 654983 [details] [diff] [review]
Don't convert DIV to P when it only contains a SELECT node

[Approval Request Comment]
User impact if declined: Some websites with SELECT elements with tons of options might affect readability parsing leading to reader showing just a bunch SELECT elements in reader mode for websites like cnn.com.
Testing completed (on m-c, etc.): Local testing on mentioned websites and others, no regressions found.
Risk to taking this patch (and alternatives if risky): Low as it only affect a very specific type of content (DIVs with only a SELECT item inside).
String or UUID changes made by this patch: None.
Attachment #654983 - Flags: approval-mozilla-aurora?
Priority: -- → P2
https://hg.mozilla.org/mozilla-central/rev/66cd9a420997
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 654983 [details] [diff] [review]
Don't convert DIV to P when it only contains a SELECT node

[Triage Comment]
Approving for Beta 17 given this is a low risk fix for a regression in a new feature.
Attachment #654983 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+
This issue seems to be fixed after I loaded the pages from comment #0 on the latest Nightly, Aurora and Beta builds. Closing bug as verified fixed.

--
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.