Closed Bug 785425 Opened 10 years ago Closed 10 years ago

Work - Cleanup the formassistant module

Categories

(Firefox for Metro Graveyard :: Input, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jimm, Unassigned)

References

Details

(Whiteboard: [forms] feature=work)

This module isn't really working well as it is and will likely need updates after the selection overhaul lands.
Blocks: 786121
Blocks: 785534
Assignee: nobody → jmathies
No longer blocks: 785534
Component: General → Input
Product: Firefox → Firefox for Metro
Depends on: 801144
Assignee: jmathies → nobody
Blocks: 801144
No longer depends on: 801144
Whiteboard: [LOE:?]
Blocks: 831982
No longer blocks: 801144
No longer depends on: 781487
Summary: Overhaul form input module (forms.js) for metro → Work - Overhaul form input module (forms.js) for metro
Whiteboard: [LOE:?] → feature=work
Assignee: nobody → jmathies
This is blocked higher up by a metrov1onhold tracking bug, which doesn't fit. This bug is about reworking the form input module to get form interaction working - form inputs scrolling into view, moving elements out of the way of the soft keyboard, removing old fennec code we aren't using, etc..
Whiteboard: feature=work → [feature=work][metro-mvp?]
Blocks: 841799
Blocks: 842162
Depends on: 842516
Whiteboard: [feature=work][metro-mvp?] → feature=work
No longer blocks: 841799
Duplicate of this bug: 841799
No longer blocks: 842162
Duplicate of this bug: 842162
Blocks: 831980
Blocks: 831979
Assignee: jmathies → nobody
No longer blocks: 831980
Whiteboard: feature=work → [forms] feature=work
Some of this work was completed in bug 851657. The module still needs reformatting and better commenting.
Summary: Work - Overhaul form input module (forms.js) for metro → Work - Cleanup the formassistant module
No longer blocks: 831982
We can do this as we go.
No longer blocks: 831979, 786121
Status: NEW → RESOLVED
Closed: 10 years ago
No longer depends on: 842516
Resolution: --- → INVALID
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.