Last Comment Bug 785528 - Don't allow deletion of doctype nodes in the markup panel
: Don't allow deletion of doctype nodes in the markup panel
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 17
Assigned To: Dave Camp (:dcamp)
:
: Patrick Brosset <:pbro>
Mentors:
Depends on:
Blocks: 785380
  Show dependency treegraph
 
Reported: 2012-08-24 15:09 PDT by Dave Camp (:dcamp)
Modified: 2012-08-25 17:03 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.72 KB, patch)
2012-08-24 15:09 PDT, Dave Camp (:dcamp)
jwalker: review+
Details | Diff | Splinter Review
patch to land (1.81 KB, patch)
2012-08-24 18:01 PDT, Dave Camp (:dcamp)
no flags Details | Diff | Splinter Review
bustage fix (1.04 KB, patch)
2012-08-24 20:39 PDT, Dave Camp (:dcamp)
no flags Details | Diff | Splinter Review

Description Dave Camp (:dcamp) 2012-08-24 15:09:16 PDT
Created attachment 655180 [details] [diff] [review]
v1

This patch prevents deletion of the doctype tag, and moves protection of other tags from the delete key handler to the deleteNode method.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-24 15:37:58 PDT
Added dependency
Comment 2 Dave Camp (:dcamp) 2012-08-24 18:01:58 PDT
Created attachment 655234 [details] [diff] [review]
patch to land

Brought in the fix to this patch from bug 785380.
Comment 4 Dave Camp (:dcamp) 2012-08-24 20:39:38 PDT
Created attachment 655260 [details] [diff] [review]
bustage fix

I didn't move the fix over from 785380 correctly.  I landed this fix with r=jwalker, since it's what he reviewed over on bug 785380.

https://hg.mozilla.org/integration/fx-team/rev/5fa145ef906a

Note You need to log in before you can comment on or make changes to this bug.