Last Comment Bug 785583 - BluetoothReplyRunnable instantiates nsAutoPtr template in the header
: BluetoothReplyRunnable instantiates nsAutoPtr template in the header
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla17
Assigned To: David Zbarsky (:dzbarsky)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: b2g-bluetooth
  Show dependency treegraph
 
Reported: 2012-08-24 21:25 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-08-25 19:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (3.75 KB, patch)
2012-08-24 21:39 PDT, David Zbarsky (:dzbarsky)
kyle: review+
Details | Diff | Splinter Review

Description David Zbarsky (:dzbarsky) 2012-08-24 21:25:42 PDT
GCC warns that the destructor won't be called because we don't have the full definition of BluetoothReply.
Comment 1 David Zbarsky (:dzbarsky) 2012-08-24 21:39:18 PDT
Created attachment 655268 [details] [diff] [review]
Patch
Comment 2 Kyle Machulis [:qdot] 2012-08-24 21:56:42 PDT
Comment on attachment 655268 [details] [diff] [review]
Patch

Review of attachment 655268 [details] [diff] [review]:
-----------------------------------------------------------------

Been meaning to clean that up for a while, thanks!
Comment 3 David Zbarsky (:dzbarsky) 2012-08-25 09:34:31 PDT
No problem.
https://hg.mozilla.org/integration/mozilla-inbound/rev/f7e7a78f6ff4
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-25 19:26:58 PDT
https://hg.mozilla.org/mozilla-central/rev/f7e7a78f6ff4

Note You need to log in before you can comment on or make changes to this bug.