java.lang.NullPointerException: at org.mozilla.gecko.GeckoAppShell$10.run(GeckoAppShell.java)

VERIFIED FIXED in Firefox 17

Status

()

--
critical
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: scoobidiver, Assigned: kats)

Tracking

({crash, regression, topcrash})

17 Branch
Firefox 18
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox17+ verified, firefox18 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
It's a low volume crash but there's a spike in crashes starting from 17.0a1/20120824. It has been hit by 10 users in less than one day.
The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5650196a8c7d&tochange=1c0ac073dc65

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoAppShell$10.run(GeckoAppShell.java:1505)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4511)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:980)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:747)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoAppShell%2410.run%28GeckoAppShell.java%29
GeckoApp.mAppContext.getLayerView() is returning null, probably because of an activity restart. This is likely a regression from bug 781220. Patch coming shortly.
Assignee: nobody → bugmail.mozilla
Blocks: 781220
Created attachment 655590 [details] [diff] [review]
Patch
Attachment #655590 - Flags: review?(sriram)
Comment on attachment 655590 [details] [diff] [review]
Patch

Review of attachment 655590 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #655590 - Flags: review?(sriram) → review+

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/c7e7eb166dd9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
(Reporter)

Updated

6 years ago
status-firefox17: --- → affected
tracking-firefox17: ? → +
Looks like this missed the merge, let's get an uplift nomination and land to Aurora.
Comment on attachment 655590 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 781220
User impact if declined: low-volume crash
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile-only, low-risk
String or UUID changes made by this patch: none
Attachment #655590 - Flags: approval-mozilla-aurora?
status-firefox18: --- → fixed
Attachment #655590 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Latest crash on Aurora channel was on 2012-09-14 with the following build id: 20120903042010 which doesn't contain the patch. There is no crash on Nightly. It seems that the bug was fixed. Closing it as verified fixed
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
status-firefox18: fixed → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.