Huge increase of the resident memory use during playing canvas demo of paper.js with hardware acceleration enabled

RESOLVED DUPLICATE of bug 767337

Status

()

defect
RESOLVED DUPLICATE of bug 767337
7 years ago
4 years ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

({regression, testcase})

7 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Memshrink:P2])

Attachments

(4 attachments)

Reporter

Description

7 years ago
Open this canvas demo (bouncing balls) of paper.js:
http://paperjs.org/examples/bouncing-balls/
Click with the mouse pointer to add 4-5 balls.
You can use about:memory or the OS process manager to control the resident memory use.

Result:
With HWA on, the resident memory use increases immediately and quickly (in 5-10 sec) to the max (in my case, it was > 2GB). With HWA off, the memory use is normal (slight increase).
NB: In both cases, there is visible peak of CPU charge during the canvas animation.

I tested with various versions and I found this increase of the memory use appears with the implementation of the Direct2D Azure Backend in FF7.

Mozregression range:

m-c
good=2011-06-25
bad=2011-06-26
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ce10fd5d82c6&tochange=fc7d76664c79

m-i
good=2011-06-24
bad=2011-06-25
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=58f8e32a9faf&tochange=f5a40a6bcddb

Suspected bug:
Bug 651858 - [Azure] Implement Direct2D Azure Backend
Reporter

Updated

7 years ago
Blocks: 651858
Keywords: regression, testcase
Whiteboard: [Memshrink]
Reporter

Comment 1

7 years ago
Reporter

Comment 2

7 years ago
Posted file about:memory log
Reporter

Comment 3

7 years ago
Reporter

Comment 4

7 years ago
Testcase can be downloaded here: http://paperjs.org/download/

Comment 5

7 years ago
I don't know if it's related, but in addition to the memory increase, I get some slowdowns, the canvas becomes blank momentarily, and if I try to change tabs during these problems the browser tabs lose their background (gradients?).


http://i.imgur.com/otYiC.png
This sounds similar to bug 767337.  Nick Cameron, can you take a look?  Or maybe Bas, if it's an Azure thing?
Whiteboard: [Memshrink] → [Memshrink:P2]
I had a quick look at this and I am pretty sure it is the same as bug 767337 - I can't reproduce the excessive memory use, because the fix for 767337 cures my setup, but not Loic's, so that fits. And the test case uses lots of gradients, which is the same source of excessive memory use as 767337.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767337
(In reply to jorge alves from comment #5)
> I don't know if it's related, but in addition to the memory increase, I get
> some slowdowns, the canvas becomes blank momentarily, and if I try to change
> tabs during these problems the browser tabs lose their background
> (gradients?).
> 
> 
> http://i.imgur.com/otYiC.png

Jorge: could you please copy your about:support here please so we can check your HW/driver versions?
You need to log in before you can comment on or make changes to this bug.