Garbage of tooltip is drawn on top of Dropdown arrow panel [Wndows7 Classic and disabled "Show shadow under windows" in the "performance options" of "visual effects"]

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: alice0775, Assigned: enndeakin)

Tracking

({qawanted, regression, reproducible})

17 Branch
x86
Windows 7
qawanted, regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17-)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 655425 [details]
Screen shot

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/b3cce81fef1a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120826030526

Steps To Reproduce:
1. Click Downloads toolbar button at the right side of Navbar
2. Do not move mouse pointer til tooltip pops up
3. Move mouse pointer outside of the toolbutton

Actual Results:
  Garbage(tooltip) is drawn on top of the Downloads arrow panel

Expected Results:
  Should not
(Reporter)

Updated

6 years ago
Severity: normal → trivial
(Reporter)

Comment 1

6 years ago
Created attachment 655427 [details]
screen shot

Steps To Reproduce:
0-1. Start Firefox with New Profile
0-2. (to reproduce problem easily) Don't hide Notification bar
1. Click Downloads toolbar button at the right side of Navbar
2. Do not move mouse pointer til tooltip pops up
3. Move mouse pointer outside of the toolbutton
Attachment #655425 - Attachment is obsolete: true
(Reporter)

Comment 2

6 years ago
This problem happens on Identity Popup panel, Edit Bookmarks Panel as well.
Summary: Garbage of tooltip is drawn on top of Downloads arrow panel → Garbage of tooltip is drawn on top of Dropdown arrow panel
(Reporter)

Comment 3

6 years ago
In adittion to the Comment#0 and Comment#1, you may need to maximize browser or move browser at the top of the screen.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/23a7ba542bb5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120730135738
Bad:
http://hg.mozilla.org/mozilla-central/rev/1ab429a89429
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120731055938
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=23a7ba542bb5&tochange=1ab429a89429

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/56e0971c81ea
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120730192943
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6d9745a02c2d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120730194637
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=56e0971c81ea&tochange=6d9745a02c2d
Keywords: regression
(Reporter)

Comment 4

6 years ago
This seems to happen only in  Wndows7 Classic and disabled "Show shadow under windows" in the "performance options" of "visual effects".
Summary: Garbage of tooltip is drawn on top of Dropdown arrow panel → Garbage of tooltip is drawn on top of Dropdown arrow panel [Wndows7 Classic and disabled "Show shadow under windows" in the "performance options" of "visual effects"]
(Reporter)

Comment 5

6 years ago
In local build
Last good: de293780ba8a
First bad: b8a0228a10fa

Triggered by: b8a0228a10fa	Neil Deakin — Bug 357725, support minimum and maximum size constraints on windows and popups, r=mats,jmathies,karlt,smichaud,sr=neil
Blocks: 357725
Component: Graphics → Widget
(Reporter)

Updated

6 years ago
tracking-firefox17: --- → ?
(Reporter)

Comment 6

6 years ago
Annoy behavior

STR
1. Maximize(w/ disabled menubar) or Fullscreen
2. Double Click StaUI in the nNavbar
3. Mouse hover expand tree button and wait til tooltip pops up
4. Move mouse pointer to hide tooltip

Actual Results
 Garbage of tooltip is drawn
Severity: trivial → normal
(Reporter)

Comment 7

6 years ago
screen capture http://youtu.be/CRE6aP0_euQ
(Reporter)

Comment 8

6 years ago
Created attachment 655698 [details]
The size of garbage seems to be depend on TitleBar size
Assignee: nobody → enndeakin
tracking-firefox17: ? → +
Keywords: reproducible
Tracking this regression for 17, hopefully Neil can take a look and see if we need to backout bug 357725 or if there's a possible forward-fix.
(Assignee)

Comment 10

6 years ago
I don't see the bug. Could be specific to some video settings perhaps?
(Reporter)

Comment 11

6 years ago
(In reply to Neil Deakin from comment #10)
> I don't see the bug. Could be specific to some video settings perhaps?

*Wndows7 Classic
*Disabled "Show shadow under windows" in the "performance options" of "visual effects" 
*TitleBar size: smaller size than default or equal
*Position of the browser: Maximize/FullScreem or  moved browser to upper screen in normal mode
*Graphics
    Adapter Description: ATI Radeon HD 4300/4500 Series
    Vendor ID: 0x1002
    Device ID: 0x954f
    Adapter RAM: 512
    Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
    Driver Version: 8.970.100.3000
    Driver Date: 7-3-2012
    Direct2D Enabled: true
    DirectWrite Enabled: true (6.1.7601.17789)
    ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50 
    WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
    GPU Accelerated Windows: 1/1 Direct3D 10
    AzureCanvasBackend: direct2d
    AzureFallbackCanvasBackend: cairo
    AzureContentBackend: direct2d
(Assignee)

Comment 12

6 years ago
Possibly it only occurs when acceleration is enabled, which doesn't work on my machine.
Adding qawanted then to see if someone can reproduce this on a machine with acceleration enabled. Neil can you get access to a machine in Toronto with acceleration to be able to work on a fix for this?  We can loop in Desktop Support here too if you need a machine provided.
Keywords: qawanted, verifyme
I can't reproduce this with or without acceleration on my Intel machine, sadly. :(
I take that back. Somehow my machine switched from Windows Classic back to Aero and I didn't notice. I can reproduce this only with hardware acceleration enabled.
Juan, can you please have a look at this on one of the lab machines?
QA Contact: jbecerra
Random stab in the dark: can someone try this try build to see if it fixes the problem? (It will show up in a few hours)

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-ed2919fc72d9
(Reporter)

Comment 19

6 years ago
tnikkel@gmail.com-ed2919fc72d9  --- Nothing seems to have changed
tnikkel@gmail.com-a5b3e1cef487  --- Nothing seems to have changed
tnikkel@gmail.com-02562f282827  --- Nothing seems to have changed
tnikkel@gmail.com-05f950fc8677  --- Nothing seems to have changed
This is a minor issue in a very unusual set of circumstances, so I'd like to propose that this not be tracked.
tracking-firefox17: + → ?
Concur!  Untracking.
tracking-firefox17: ? → -
(Reporter)

Comment 22

6 years ago
> very unusual set of circumstances
I do not think that "Windows Classic" and Disabled "Show shadow under windows" is very unusual set  of circumstances...
The patch in bug 802456 should fix this.
Depends on: 802456
Should be fixed by bug 802456 now. Please reopen if not.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.