Clumsy handling of text/html attachments

VERIFIED DUPLICATE of bug 46655

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 46655
18 years ago
10 years ago

People

(Reporter: Miguel Covarrubias, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Emails with text/html attachments are not showing the attachments inline.  When
trying to open the text/html attachments, a dialog comes up that says:

This file has mime type text/html and cannot be viewed using Mozilla.  You can
open it with another application, or save it to disk.

Shouldn't mail be able to handle html attachments a little more smoothly than this?
Does that attachment really have the text/html mimetype?  Or is it attached as
something wacky?  That dialog has a known truthfulness problem....
(Reporter)

Comment 2

18 years ago
I think you may right...

Netscape 4.61 reports the file's mime type as application/octet-stream.  The
file is called "blah.htm", and it really is an HTML file, despite the
octet-stream type it was assigned.  Netscape 4.61 does not render the attachment
inline but will open a Communicator window without complaint to view the attachment.
I would say that what you're seeing is a combination of bug 46655 (the dialog
reporting the wrong mimetype) and bug 52441 (which means that on Linux we don't
properly map the .htm extension to the text/html mimetype).
(Reporter)

Comment 4

18 years ago
Yes, I think I agree with that.  Certainly there's some bug 46655 going on here:
the mime type is actually application/octet-stream but it's reported as
text/html.  And quite possibly if bug 52441 were addressed and Mozilla could
associate .htm files with the text/html mimetype, this problem might disappear.

Comment 5

17 years ago
Duping

*** This bug has been marked as a duplicate of 46655 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Mark it as verified/dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.