Last Comment Bug 785828 - Ensure that libxul.so is loaded lazily
: Ensure that libxul.so is loaded lazily
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: OS.File (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla18
Assigned To: David Teller [:Yoric] (please use "needinfo")
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 03:29 PDT by David Teller [:Yoric] (please use "needinfo")
Modified: 2012-09-18 08:23 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Load libxul.so lazily (6.03 KB, patch)
2012-08-27 03:29 PDT, David Teller [:Yoric] (please use "needinfo")
nfroyd: review+
Details | Diff | Splinter Review
Load libxul.so lazily (6.04 KB, patch)
2012-08-28 05:09 PDT, David Teller [:Yoric] (please use "needinfo")
dteller: review+
Details | Diff | Splinter Review
backport to aurora (6.15 KB, patch)
2012-09-17 09:51 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description David Teller [:Yoric] (please use "needinfo") 2012-08-27 03:29:02 PDT

    
Comment 1 David Teller [:Yoric] (please use "needinfo") 2012-08-27 03:29:36 PDT
Created attachment 655551 [details] [diff] [review]
Load libxul.so lazily

Here we go.
Comment 2 Nathan Froyd [:froydnj] 2012-08-27 08:17:57 PDT
Comment on attachment 655551 [details] [diff] [review]
Load libxul.so lazily

Review of attachment 655551 [details] [diff] [review]:
-----------------------------------------------------------------

IIUC, we don't have to modify back-end specific things because they don't interact with libxul, correct?
Comment 3 David Teller [:Yoric] (please use "needinfo") 2012-08-27 08:56:04 PDT
Indeed, at the moment, nothing interacts with libxul besides the string-related functions patched here.
Comment 4 David Teller [:Yoric] (please use "needinfo") 2012-08-28 05:09:59 PDT
Created attachment 655957 [details] [diff] [review]
Load libxul.so lazily
Comment 5 David Teller [:Yoric] (please use "needinfo") 2012-08-28 05:23:40 PDT
For reference, loading libxul.so eagerly causes all sorts of "interesting" errors during the construction of the startup cache. I tend to believe that this is actually a design error in the startup cache, but loading libxul.so lazily makes sense, in addition of postponing the time at which we will need to fix the startup cache construction.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-28 05:33:18 PDT
https://tbpl.mozilla.org/?tree=Try&rev=ce0eb243566d
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-08-28 10:26:24 PDT
(In reply to Ryan VanderMeulen from comment #6)
> https://tbpl.mozilla.org/?tree=Try&rev=ce0eb243566d

Green on Try.

https://hg.mozilla.org/integration/mozilla-inbound/rev/04d13cf166ab
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-28 17:10:52 PDT
https://hg.mozilla.org/mozilla-central/rev/04d13cf166ab
Comment 9 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-09-17 09:51:47 PDT
Created attachment 661829 [details] [diff] [review]
backport to aurora

Try run at https://tbpl.mozilla.org/?tree=Try&rev=099466ea69fc

Porting this patch to Aurora makes it safer to port the patch in bug 787334 and that one fixes "make package" for XULRunner.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: None
Testing completed (on m-c, etc.): Try is running. 
Risk to taking this patch (and alternatives if risky): Build problems. 
String or UUID changes made by this patch: None
Comment 10 Lukas Blakk [:lsblakk] use ?needinfo 2012-09-17 15:37:07 PDT
Comment on attachment 661829 [details] [diff] [review]
backport to aurora

Looks like it will be obvious if this doesn't work on Aurora, approving.
Comment 11 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-09-18 06:58:38 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/4d10018bb0f0

Note You need to log in before you can comment on or make changes to this bug.