Closed Bug 785885 Opened 8 years ago Closed 8 years ago

Adjust/tweak text positioning in landscape layout in about:feedback

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox16 --- verified
firefox17 --- verified
firefox18 --- verified

People

(Reporter: aaronmt, Assigned: Margaret)

References

Details

Attachments

(2 files)

See screenshot.

--
Nightly (08/27), Galaxy Nexus (Android 4.1.1)
Oof, good catch.
Assignee: nobody → margaret.leibovic
Attached patch patchSplinter Review
The problem was caused by the fact that we use position: absolute; on these bottom-aligned divs. To fix that, I used media queries to just add some top margin instead if the screen height is less than 400px. I also took this opportunity to get rid of the top padding on the body when the screen height is too small, to avoid needing to scroll the page.

I just picked 400px because that seems to do the job. Is there something smarter I should be doing? I considered doing portrait/landscape, but I didn't want to affect tablets.
Attachment #655712 - Flags: review?(mark.finkle)
Comment on attachment 655712 [details] [diff] [review]
patch

Margaret answered my nags on IRC. Please try using "device-height" and see if VKB still affects the layout. If not, use it. If so, stick with "max-height".
Attachment #655712 - Flags: review?(mark.finkle) → review+
I tried using device-height, but I couldn't find a pixel value that worked on both my Galaxy Nexus and my Nexus S, perhaps because the menu buttons on the Galaxy Nexus were being included in the device height value (this is just a guess). Anyway, basing the calculation on the size of the content seems to make the most sense, so I just stuck with that. If we find that this has bad interactions with the VKB, we can file a follow-up, but I was already seeing a redraw flash when the VKB came up before this creating this patch, so it seems there are different problems there.

https://hg.mozilla.org/integration/mozilla-inbound/rev/c1a0b963ffb1
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/c1a0b963ffb1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 655712 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feedback solicitation (bug 774479)
User impact if declined: styling is bad in landscape mode
Testing completed (on m-c, etc.): landed on m-c 8/28
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: n/a
Attachment #655712 - Flags: approval-mozilla-aurora?
Attachment #655712 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 655712 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feedback solicitation (bug 774479)
User impact if declined: styling is bad in landscape mode
Testing completed (on m-c, etc.): landed on m-c 8/28
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: n/a
Attachment #655712 - Flags: approval-mozilla-beta?
Comment on attachment 655712 [details] [diff] [review]
patch

[Triage Comment]
We've just approved the feedback solicitation bug for Beta - let's land this at the same time.
Attachment #655712 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified fixed.

Build: Firefox 18.0a1 (2012-09-04), Firefox 17.0a2 (2012-09-04)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
Status: RESOLVED → VERIFIED
Text is displayed in the correct position on the latest Beta build.

Firefox Mobile 16.0b5
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
You need to log in before you can comment on or make changes to this bug.