Last Comment Bug 785927 - js/src/vm/ObjectImpl-inl.h:214:1: warning: unused function 'IsValueInCompartment' [-Wunused-function]
: js/src/vm/ObjectImpl-inl.h:214:1: warning: unused function 'IsValueInCompartm...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla18
Assigned To: Terrence Cole [:terrence]
:
Mentors:
: 785589 (view as bug list)
Depends on:
Blocks: 776583
  Show dependency treegraph
 
Reported: 2012-08-27 10:03 PDT by Gregory Szorc [:gps]
Modified: 2012-08-27 19:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0: trivial (1.13 KB, patch)
2012-08-27 10:11 PDT, Terrence Cole [:terrence]
terrence: review+
gps: feedback+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2012-08-27 10:03:11 PDT
I pulled m-c for the first time in about a week this morning and got a new compiler warning:

js/src/vm/ObjectImpl-inl.h:214:1: warning: unused function 'IsValueInCompartment' [-Wunused-function]

I'm seeing it repeated a few dozen times (because the header is included many places, I assume).

I'm building with Clang SVN HEAD minus a week or two on OS X.
Comment 1 Terrence Cole [:terrence] 2012-08-27 10:09:26 PDT
Looks like I forgot #ifdef DEBUG markers around it.  Thanks for filing.
Comment 2 Terrence Cole [:terrence] 2012-08-27 10:11:56 PDT
Created attachment 655628 [details] [diff] [review]
v0: trivial
Comment 3 Gregory Szorc [:gps] 2012-08-27 10:14:46 PDT
Comment on attachment 655628 [details] [diff] [review]
v0: trivial

Review of attachment 655628 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not a peer for the JS module, so I don't think I can give r+. It looks good to me though.
Comment 4 Terrence Cole [:terrence] 2012-08-27 10:28:21 PDT
I consider it a build issue, not a JS issue as such, but whatever.
Comment 5 Terrence Cole [:terrence] 2012-08-27 10:36:54 PDT
Comment on attachment 655628 [details] [diff] [review]
v0: trivial

r+ from bhackett on IRC with feedback from Waldo that I should make it inline instead of static, since inline implies static in C++.
Comment 6 Terrence Cole [:terrence] 2012-08-27 10:46:46 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/72bb1083fbab
Comment 7 Terrence Cole [:terrence] 2012-08-27 11:44:37 PDT
*** Bug 785589 has been marked as a duplicate of this bug. ***
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-08-27 19:18:20 PDT
https://hg.mozilla.org/mozilla-central/rev/72bb1083fbab

Note You need to log in before you can comment on or make changes to this bug.