Add more localization notes to about:feedback strings to clarify tone/intent

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
9 months ago

People

(Reporter: Margaret, Assigned: Margaret)

Tracking

Trunk
Firefox 18
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 verified, firefox17 verified, firefox18 verified, firefox19 verified, firefox20 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We should add more notes to the about:feedback string to make sure localizes understand where we're trying to inject some whimsy, because translating some of these string literally might not work out well (e.g. "Or else.").

Matej, maybe you have some ideas about what we should put in these notes? I feel like we should let localizers do what will work best in their locale, but giving some direction about our intent would be good.

https://hg.mozilla.org/mozilla-central/file/20b009e26b4c/mobile/android/locales/en-US/chrome/aboutFeedback.dtd

Comment 1

5 years ago
Yup, definitely a good idea. Let me know if the following is clear:


Somewhere near the beginning:

The text in some of these strings is supposed to be fun and playful. Please feel free to adjust the tone as works best in your language and/or locale. More detailed notes below.


Line 21:

"Share the love" — this feels purposely exaggerated in English, but essentially it means that we want you to let others know how much you love Firefox


Line 22:

"Feels great" — another exaggeration where we're trying to get people to rate us by playfully telling them there's a benefit in it for them as well


Line 36:

"Real people" — we're stating that an actual human will look at the feedback and that it doesn't just go to some automated system that looks for keywords, or something like that


Line 37:

"Or else" — we're suggesting that there will be consequences for the people working on Firefox if they don't resolve the user's problem, like "or if they don't fix it, we'll fire them." If this doesn't work in your language, you can change it to something like "no matter what" or just remove it entirely.


Line 39:

"Just the ones about..." — in English, "please share your thoughts" could mean that we're asking the user to tell us any thoughts or ideas they have about anything, so we're jokingly telling them not to use the space below to tell us anything they're thinking about


Line 46:

"High five" — this is a celebratory or congratulatory gesture. It could also be a handshake, a pat on the back, a thumbs up or something similar. The idea is that it's something physical, which is why they can't see it.
(Assignee)

Comment 2

5 years ago
Created attachment 655801 [details] [diff] [review]
patch

Thanks for the detailed notes, Matej!

I added them to aboutFeedback.dtd.
Assignee: nobody → margaret.leibovic
Attachment #655801 - Flags: review?(mark.finkle)
Attachment #655801 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ca2c9d69386
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/5ca2c9d69386
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

5 years ago
Comment on attachment 655801 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feedback solicitation (bug 774479)
User impact if declined: localizers will have a harder time translating strings, potentially missing our intended tone
Testing completed (on m-c, etc.): landed on m-c 8/28
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: n/a (just changes localization notes)
Attachment #655801 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #655801 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Approving as there are no string changes.
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/73a9d79c8fbd
status-firefox16: --- → unaffected
status-firefox17: --- → fixed
status-firefox18: --- → fixed
(Assignee)

Comment 8

5 years ago
Comment on attachment 655801 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): feedback solicitation (bug 774479)
User impact if declined: localizers will have a harder time translating strings, potentially missing our intended tone
Testing completed (on m-c, etc.): landed on m-c 8/28
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: n/a (just changes localization notes)
Attachment #655801 - Flags: approval-mozilla-beta?

Updated

5 years ago
Attachment #655801 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/e5b9e22609fc
status-firefox16: unaffected → fixed

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
Notes were added on all branches
http://mxr.mozilla.org/mozilla-release/source/mobile/android/locales/en-US/chrome/aboutFeedback.dtd
status-firefox17: fixed → verified
status-firefox18: fixed → verified
status-firefox19: --- → verified
status-firefox20: --- → verified
You need to log in before you can comment on or make changes to this bug.