Support local and remoteDescription attributes for JSEP

RESOLVED DUPLICATE of bug 797534

Status

()

P2
normal
RESOLVED DUPLICATE of bug 797534
6 years ago
6 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc+])

Attachments

(1 attachment)

Comment hidden (empty)

Updated

6 years ago
Whiteboard: [WebRTC], [blocking-webrtc+]
The PeerConnection object needs .localDescription and .remoteDescription attributes. These are readonly attribute (but can be set via setLocalDescription/setRemoteDescription), and return empty strings if a local or remote description hasn't been set.
(Assignee)

Comment 2

6 years ago
Created attachment 692637 [details] [diff] [review]
Add support for localDescription and remoteDescription (still needs updating with ICE)

Not complete; this doesn't include ICECandidate updates.  Not tested yet.
(Assignee)

Updated

6 years ago
Assignee: nobody → rjesup
Priority: -- → P2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797534
You need to log in before you can comment on or make changes to this bug.