Make imgFrame locks counted instead of boolean

RESOLVED DUPLICATE of bug 786444

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 786444
5 years ago
5 years ago

People

(Reporter: Joe Drew (not getting mail), Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
As part of bug 486918, I want to make it possible to have multiple downscaled images, but doing that makes necessary to lock an imgFrame multiple times. So, instead of trying to only lock when it's not locked, I'm just going to make imgFrame locks counted, like RasterImage already is.

First, I need to make our locking correct - always lock when you're going to GetImageData/GetPaletteData. To do that, I'm introducing an RAII class, which I'm sure will make jrmuizel *ecstatic*.
(Reporter)

Comment 1

5 years ago
thanks for the HTTP 500 error, bugzilla
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786444
No longer blocks: 486918
You need to log in before you can comment on or make changes to this bug.