Background tabs cause multiple whole window repaints

RESOLVED DUPLICATE of bug 786484

Status

()

defect
RESOLVED DUPLICATE of bug 786484
7 years ago
7 years ago

People

(Reporter: taras.mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy])

(Reporter)

Description

7 years ago
1.Turn on nglayout.debug.paint_flashing pref.
2. Load a page in a background tab
3. Observe foreground tab & rest of window repaint twice once page finishes loading. 

I guess this has something to do with tab reflows
Depends on: dlbi
I wasn't able to reproduce this on Linux, Windows XP, or Mac.
(Reporter)

Comment 2

7 years ago
(In reply to Timothy Nikkel (:tn) from comment #1)
> I wasn't able to reproduce this on Linux, Windows XP, or Mac.

Thanks for trying. I tried a build with a clean profile. It does not exhibit this behavior. I'm going to keep narrowing down differences between the two profiles until I figure this out.
We specifically kill invalidates that come from inside background tabs, so if this was happening it would be very interesting.
(Reporter)

Comment 4

7 years ago
Narrowed this down to browser.newtab.preload being set to true in my profile.
Depends on: 753448
I can reproduce this on Mac. Setting the "busy" attribute on the tab is what causes the repaint - removing the attribute doesn't cause another repaint. This only happens if new tab preloading is enabled.

Theory: the hidden iframe in the window is causing us to unnecessarily repaint the whole window when certain chrome style changes occur.
OS: Windows 7 → All
Hardware: x86_64 → All
Blocks: 753448
No longer depends on: 753448
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #5)
> I can reproduce this on Mac. Setting the "busy" attribute on the tab is what
> causes the repaint - removing the attribute doesn't cause another repaint.
> This only happens if new tab preloading is enabled.
> 
> Theory: the hidden iframe in the window is causing us to unnecessarily
> repaint the whole window when certain chrome style changes occur.

So this is essentially a duplicate of bug 786484.
No longer blocks: 753448
Status: NEW → RESOLVED
Last Resolved: 7 years ago
No longer depends on: dlbi
Resolution: --- → DUPLICATE
Duplicate of bug: 786484
You need to log in before you can comment on or make changes to this bug.