Firefox file picker is triggered when clearing the Android notifications after a file was already downloaded

VERIFIED FIXED in Firefox 17

Status

()

Firefox for Android
Download Manager
VERIFIED FIXED
5 years ago
10 months ago

People

(Reporter: xti, Assigned: wesj)

Tracking

16 Branch
Firefox 18
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16+ unaffected, firefox17+ fixed, firefox18 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Firefox 18.0a1 (2012-08-28)
Device: Galaxy Note
OS: Android 4.0.4

Steps to reproduce:
1. Open Fennec
2. Go to http://1.usa.gov/deeXKM
3. After the download is completed, the file picker is triggered or the file is opened directly. In any of these cases, tap on the Back button to go back to Fennec main view
4. Drag down the Android notification bar and tap on Clear button

Expected result:
All Android notifications are cleared, including the Firefox complete download notification.

Actual result:
File picker is triggered, or the file is opened directly by a default 3rd party app.

Note:
This issue is not reproducible on the stock browser.
This sounds like an Android issue.
(Reporter)

Comment 2

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> This sounds like an Android issue.

It should be the same behavior on the stock then, right?
(Assignee)

Comment 3

5 years ago
Created attachment 656482 [details] [diff] [review]
Patch

The notification handler registers for two intents that we specify when we create the notification. ACTION_ALERT_CLICK and ACTION_ALERT_CLEAR. We're currently doing the same thing in both cases.
Attachment #656482 - Flags: review?(mark.finkle)
Attachment #656482 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f8254a69dff0
(Assignee)

Comment 5

5 years ago
Comment on attachment 656482 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 781061
User impact if declined: Clearing notifications is the same as clicking on them
Testing completed (on m-c, etc.): Landed on mc right now 8/29
Risk to taking this patch (and alternatives if risky): Really low risk. Alternatively, we could back 781061 out of beta since webapps are turned off there.
String or UUID changes made by this patch: None.
Attachment #656482 - Flags: approval-mozilla-beta?
Attachment #656482 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
status-firefox17: --- → affected
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
tracking-firefox16: ? → +
tracking-firefox17: ? → +
https://hg.mozilla.org/mozilla-central/rev/f8254a69dff0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

5 years ago
status-firefox18: affected → fixed

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox18: fixed → verified

Comment 7

5 years ago
Comment on attachment 656482 [details] [diff] [review]
Patch

[Triage Comment]
Approving for Aurora 17. No need to land on Beta 16, because we've already backed out bug 781061. Thanks wesj.
Attachment #656482 - Flags: approval-mozilla-beta?
Attachment #656482 - Flags: approval-mozilla-beta-
Attachment #656482 - Flags: approval-mozilla-aurora?
Attachment #656482 - Flags: approval-mozilla-aurora+

Comment 8

5 years ago
(please correct me if I'm wrong here about 16)
status-firefox16: affected → fixed
(Reporter)

Comment 9

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #8)
> (please correct me if I'm wrong here about 16)

Still occurs on the latest Beta build.

--
Firefox 16.0b1 build 1
Device: Galaxy Note
OS: Android 4.0.4
status-firefox16: fixed → affected

Comment 10

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #7)
> No need to land on Beta 16, because we've already backed out bug 781061.
The backout of bug 781061 is to fix bug 786338.
(In reply to Cristian Nicolae (:xti) from comment #9)
> (In reply to Alex Keybl [:akeybl] from comment #8)
> > (please correct me if I'm wrong here about 16)
> 
> Still occurs on the latest Beta build.
> 
> --
> Firefox 16.0b1 build 1
> Device: Galaxy Note
> OS: Android 4.0.4

The backout of bug 781061 would first be testable in b2, given when it landed. Hopefully wesj can help sort out where this fix needs to land.
Assignee: nobody → wjohnston
(Assignee)

Comment 12

5 years ago
I backed this out last thursday from https://hg.mozilla.org/releases/mozilla-beta. I believe that we'd already branched for beta 1 by then and this is in beta 2.

Updated

5 years ago
status-firefox16: affected → unaffected
status-firefox17: affected → fixed
(Assignee)

Comment 13

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/eccc5df5b6af
You need to log in before you can comment on or make changes to this bug.