GetFolder: "User Pick" is not accepted as a target folder--installscript aborts

VERIFIED DUPLICATE of bug 5578

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED DUPLICATE of bug 5578
19 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: dougt)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: 6/9/99 SeaMonkey build

1. Trigger http://jimbob/jars/a_getfolder_1_userpick.jar
2. Using the form:
   f = Install.GetFolder("User Pick");
   err = Install.AddSubcomponent(regName, jarSrc, f, jarSrc);

RESULT:
Using Install.TRACE shows that err = -3 when AddSubcomponent is attempted.  This
form of AddSubcomponent works with other target folders.  The installscript
aborts gracefully.

The Install.log shows:
---------------------------------------------------------------------------
Acceptance: a_getfolder_1_userpick
---------------------------------------------------------------------------

     Starting Installation at 06/09/1999 15:37:06

     Aborted Installation at 06/09/1999 15:37:06

     Finished Installation  06/09/1999 15:37:06

EXPECTED RESULT:
Installscript does not abort.  Component is installed to the "User Pick" target
folder.  Component is registered in Version registry.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 5578 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
We'll track this from 5578.  Verifying this one out, eh.

Comment 3

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.