If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Open Containing Folder in right click menu disabled after pause

VERIFIED FIXED in Firefox 19

Status

()

Firefox
Downloads Panel
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: david.smitmanis, Assigned: mconley)

Tracking

18 Branch
Firefox 19
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When downloading a file, Open Containing Folder is available from the right-click menu. If you pause, it's disabled. This may be intentional. But if you resume the download, it's still disabled.
(Reporter)

Updated

5 years ago
Blocks: 564934
we should check whether it's expected or not.
Blocks: 747422
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted

Updated

5 years ago
Flags: needinfo?(shorlander)
(Assignee)

Comment 2

5 years ago
Created attachment 676279 [details] [diff] [review]
Patch v1
Assignee: nobody → mconley
(Assignee)

Comment 3

5 years ago
Comment on attachment 676279 [details] [diff] [review]
Patch v1

It turns out that for the Open Containing Folder menuitem, we only enable if the localfile exists. It doesn't consider part files, which are created when we pause and resume a download.
Attachment #676279 - Flags: review?(mak77)
Comment on attachment 676279 [details] [diff] [review]
Patch v1

Review of attachment 676279 [details] [diff] [review]:
-----------------------------------------------------------------

Hm, interesting, the existence of the final and .part file are somehow "random", on download start both exist, on pause the final one is removed, on resume it's not recreated and we continue downloading into the part. On cancel and retry we don't add a .part anymore and download directly to the final file.
This is not a bug in the panel though, the old DM does the same, I should check the code to see why we did these choices, or if some of those are actual regressions.

Based on this fancy behavior the patch is fine.

::: browser/components/downloads/src/DownloadsCommon.jsm
@@ +892,5 @@
> +   * Returns an nsILocalFile for aFilename. aFilename might be a file URL or
> +   * a native path.
> +   *
> +   * @param aFilename the filename of the file to retrieve.
> +   * @returns an nsILocalFile for the file.

nit: the correct form is @return (without the s)

@@ +899,5 @@
> +   *         Windows path is stored and then the item is accessed on a Mac.
> +   * @note This function makes no guarantees about the file's existence -
> +   *       callers should check that the returned file exists.
> +   */
> +  _getFile: function DDI__getDownloadFile(aFilename)

label and name are not synced
Attachment #676279 - Flags: review?(mak77) → review+
(Assignee)

Comment 5

5 years ago
Cool, thanks - corrections made. Landed on mozilla-inbound:

https://hg.mozilla.org/integration/mozilla-inbound/rev/1c09fe104280
this doesn't need design anymore.
Flags: needinfo?(shorlander)

Updated

5 years ago
Keywords: uiwanted

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/1c09fe104280
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121112030753

Verified as fixed on the latest Nightly - the 'Open Containing Folder' option in the context menu is not disabled after the pause.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.