Last Comment Bug 786690 - Fix buffered streams when outputting 16bit
: Fix buffered streams when outputting 16bit
Status: RESOLVED FIXED
: qawanted
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla18
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks: 694484
  Show dependency treegraph
 
Reported: 2012-08-29 08:34 PDT by Michael Wu [:mwu]
Modified: 2014-01-10 10:39 PST (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Fix buffered streams on 16 bit outputs (609 bytes, patch)
2012-08-29 08:34 PDT, Michael Wu [:mwu]
kinetik: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Michael Wu [:mwu] 2012-08-29 08:34:37 PDT
Created attachment 656461 [details] [diff] [review]
Fix buffered streams on 16 bit outputs
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-08-31 18:47:12 PDT
https://hg.mozilla.org/mozilla-central/rev/5071c1a3c394
Comment 3 Jan Beich 2012-10-23 22:21:07 PDT
Comment on attachment 656461 [details] [diff] [review]
Fix buffered streams on 16 bit outputs

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 775319
User impact if declined: garbled/no audio, may crash with some players
Testing completed (on m-c, etc.): already in Aurora with no issues; by me on cubeb/alsa with youtube/html5 player using freebsd where float32 doesn't work (bug 780531)
Risk to taking this patch (and alternatives if risky): none for float32, garbled/no audio for s16 (e.g. on android)
Comment 4 Alex Keybl [:akeybl] 2012-10-24 15:31:20 PDT
We'll approve this, but we need to make sure we didn't regress Firefox for Android. Can you provide some example streams for QA to test?
Comment 5 Michael Wu [:mwu] 2012-10-24 15:40:34 PDT
(In reply to Alex Keybl [:akeybl] from comment #4)
> We'll approve this, but we need to make sure we didn't regress Firefox for
> Android. Can you provide some example streams for QA to test?

Firefox for Android doesn't use this code path at all. Otherwise, it would've been discovered and fixed long ago. Firefox for Android uses sydneyaudio while this code path is for cubeb.

When this bug is triggered, the audio output is mostly noise. No special example streams are necessary.
Comment 6 Michael Wu [:mwu] 2012-10-24 15:42:04 PDT
(In reply to Jan Beich from comment #3)
> Comment on attachment 656461 [details] [diff] [review]
> Fix buffered streams on 16 bit outputs
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 775319
> User impact if declined: garbled/no audio, may crash with some players
> Testing completed (on m-c, etc.): already in Aurora with no issues; by me on
> cubeb/alsa with youtube/html5 player using freebsd where float32 doesn't
> work (bug 780531)
> Risk to taking this patch (and alternatives if risky): none for float32,
> garbled/no audio for s16 (e.g. on android)

Are you going to land it or will you need someone to land it for you?
Comment 7 Jan Beich 2012-10-24 17:37:27 PDT
(In reply to Michael Wu [:mwu] from comment #6)
> Are you going to land it or will you need someone to land it for you?

No, I have zero commit access. Please, land it to 17.0.
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-10-25 16:59:55 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/6cfacf221d96
Comment 9 Virgil Dicu [:virgil] [QA] 2012-11-12 06:42:50 PST
Is there anything specific that we can do here to verify this bug? See comment 4.
Comment 10 Michael Wu [:mwu] 2012-11-12 10:30:29 PST
(In reply to Virgil Dicu [:virgil] [QA] from comment #9)
> Is there anything specific that we can do here to verify this bug? See
> comment 4.

This bug never existed on any of our tier 1 platforms. It sounds like testing firefox on freebsd might do the trick but I dunno if there's any special configuration required to enable cubeb/alsa.
Comment 11 Virgil Dicu [:virgil] [QA] 2012-11-27 07:42:23 PST
I was not able to verify this due to lack of resources and system configuration.

Michael, can you please verify if this is fixed?
Comment 12 Tracy Walker [:tracy] 2014-01-10 10:39:48 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.