background-image disappears if rotate 90 or 270 deg

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: kpc080, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Other
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18 verified, fennec+)

Details

(Whiteboard: [games:p2], )

Attachments

(2 attachments)

Reporter

Description

7 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:10.0.5) Gecko/10.0.5 Firefox/10.0.5 Fennec/10.0.5
Build ID: 20120531185433

Steps to reproduce:

i tried out my game at http://www.philip-maerz.de/game/metrogame/
i clicked on a random moveable tile...
i'm using an acer a500


Actual results:

the background image disappeared if the rotate() value was 90 or 270 deg


Expected results:

the background image should rotate without disappearing
Component: General → Graphics, Panning and Zooming
(In reply to kpc080 from comment #0)
> User Agent: Mozilla/5.0 (Android; Mobile; rv:10.0.5) Gecko/10.0.5
> Firefox/10.0.5 Fennec/10.0.5

Really? Please confirm which version of Firefox you're using.
Component: Graphics, Panning and Zooming → General
Product: Firefox for Android → Fennec
Version: unspecified → Firefox 10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Reporter

Comment 2

7 years ago
How can i confirm it?
It's the newest version of Firefox on Android...
Go to about:firefox or about:buildconfig and provide the version numbers and/or build changeset listed there.
Reporter

Comment 5

7 years ago
At about:firefox   :
10.0.5 (en-US) mobile
That is mozilla-est10; you're going to want to upgrade to mozilla-15; Firefox for Android on Google Play .
Reporter

Comment 7

7 years ago
Updated it, same problem... I'll try to make a photo of it...
Reporter

Comment 8

7 years ago
Posted image Picture of the bug
Fields 1,2 and 9 were rotated by 90 or 270 deg.
Field 3,4 and 7 were rotated by 180 deg.
I can reproduce on latest m-c build. No idea what's causing it but I see assertions and warnings in the logcat that I've never seen before. Adding roc since he seems to have added the original "How did we snap, then?" assertion and can hopefully provide more context.

09-04 10:58:26.771 I/Gecko   (15046): ###!!! ASSERTION: How did we snap, then?: '!currentMatrix.HasNonAxisAlignedTransform()', file /home/kats/zspace/mozilla-git/layout/base/nsLayoutUtils.cpp, line 3609
09-04 10:58:26.771 I/Gecko   (15046): WARNING: Scaling up too much, bailing out: file /home/kats/zspace/mozilla-git/gfx/thebes/gfxUtils.cpp, line 326
09-04 10:58:35.435 I/Gecko   (15046): ###!!! ASSERTION: bad aListVisibleBounds: 'r.GetBounds().IsEqualInterior(aListVisibleBounds)', file /home/kats/zspace/mozilla-git/layout/base/nsDisplayList.cpp, line 869
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Component: General → General
Product: Fennec → Firefox for Android
Version: Firefox 10 → Trunk
Requesting tracking Fennec for gaming related improvements.
tracking-fennec: --- → ?
tracking-fennec: ? → +
Blocks: gecko-games
I pulled the try build from bug 777194 and that does in fact fix this bug. Marking as a dependency so that we re-test this once that lands.
Depends on: 777194
Whiteboard: [games:p2]
Fixed by checkin for bug 777194.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Posted image Nightly 09/20
This is how the game looks on latest Nightly. Is it related to this bug, or related to bug 777194? 

The block's background is still displayed as expected now.

--
Firefox 18.0a1 (2012-09-20)
Device: Galaxy Note
OS: Android 4.0.4
(In reply to Cristian Nicolae (:xti) from comment #14)
> This is how the game looks on latest Nightly. Is it related to this bug, or
> related to bug 777194? 

Are you referring to half the board being missing? That seems like a different bug to the one I just fixed.
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #15)
> Are you referring to half the board being missing? That seems like a
> different bug to the one I just fixed.

I filled bug 793629. This issue is verified on the latest Nightly. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-23)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.