All users were logged out of Bugzilla on October 13th, 2018

XUL: onchange event not fired if textbox modified during onkeyup event

RESOLVED DUPLICATE of bug 787102

Status

()

RESOLVED DUPLICATE of bug 787102
6 years ago
6 years ago

People

(Reporter: awells, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

866 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

6 years ago
Created attachment 656572 [details]
onchangeBug.xul

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

Steps to reproduce:

Typed into a textbox and an onkeyup handler raises the case of the text typed.  Tabbed off textbox and expected it to fire the onchange event.


Actual results:

The onchange event didn't fire


Expected results:

The onchange event should've fired.  This worked back in 14.0.1.  The problem is on a Mac.  I'm attaching a simple XUL file which replicates the bug.  I've tried both dynamically attaching a handler and statically referencing in the XUL and both ways exhibit the same bug.
Component: Untriaged → XUL
Product: Firefox → Core
Attachment #656572 - Attachment mime type: text/plain → application/vnd.mozilla.xul+xml

Comment 1

6 years ago
Likely a regression from bug 722599. Might be a duplicate of 787102.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
It is a duplicate indeed ;)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787102
You need to log in before you can comment on or make changes to this bug.