Last Comment Bug 786953 - XHR upload progress event not working for dropped files
: XHR upload progress event not working for dropped files
Status: RESOLVED WORKSFORME
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: 15 Branch
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 908375 1103367
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-30 01:07 PDT by Dan Günther
Modified: 2015-10-07 18:43 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
upload.zip (183.53 KB, application/octet-stream)
2012-08-30 01:07 PDT, Dan Günther
no flags Details

Description Dan Günther 2012-08-30 01:07:17 PDT
Created attachment 656774 [details]
upload.zip

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120825192214

Steps to reproduce:

I attached a simple test script for the bug I experience with Firefox 15.

The script includes a drag & drop uploader.
1. Drop any files from your system into the div element or simply all files included in the attached archive.
2. An XHR request will be made to a PHP file which uploads all your dropped files into the uploads folder.
3. A progress for each dropped file will be displayed.

Before, in Firefox 14, this script worked perfectly for any file (like it still does in Google Chrome or Internet Explorer 10). Since Firefox 15 the xhr.upload.onprogress Event doesn't fire properly anymore. It seems to only fire on images and sometimes it stops firing suddenly, so the progress calculated ends up with let's say 70%.

In any case, all files will be uploaded properly. Only the xhr.upload.onprogress behaves strangely since Firefox 15.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-08-31 20:38:00 PDT
Dan, would you be willing to use http://harthur.github.com/mozregression/ to narrow down when the problem appeared?  I totally understand if you don't have time to...

If you don't, is the actual server setup being used here available for testing against?
Comment 2 Dan Günther 2012-09-03 01:26:42 PDT
Well, I took the time and used mozregression (Windows 7) but without success. I even tested a nightly build from march 2011 with the test script attached. Last week, I uninstalled Firefox 15 on a Windows 7 virtual machine and installed Firefox 14 instead. The script worked at this time (actually, I created this script based on full functionality for Firefox 14, Google Chrome and Internet Explorer 10)!

Whatever, today I updated to Firefox 15 again to check it still doesn't work before I test with mozregression and after I uninstalled Firefox 15 again and reinstalled version 14, it now doesn't work either...I guess I broke something. Whatever, I know it worked someday before Firefox 15. :)

I use Ubuntu 12.04.1 LTS with Apache 2.2.22 installed. PHP is 5.4.4-1~oneiric+1. Apache and PHP setups are mostly default. I test in a local network on a Windows 7 x32 virtual machine. Windows 7 setup is also mostly default. During my development I used Firefox 14.0.1 on both, Ubuntu and Windows 7.

The problem isn't much of a deal for me as I can still fetch when the file is uploaded completely and display a 100% progress bar no matter what happened before (onreadystatechange event still works). When it comes to uploading bigger files, a growing progress bar looks better than a broken or no bar. So fixing this bug would only make the user waiting more comfortable, but won't change the functionality of what I actually do.

I hope anyone can reproduce this issue. I guess my test script is pretty clear and standardized. Thanks!
Comment 3 Hallvord R. M. Steen [:hallvors] 2013-09-20 02:05:49 PDT
I think this is just a specific case of bug 908375, so I'm marking as dup. We should however make sure to test this when we've fixed that..

*** This bug has been marked as a duplicate of bug 908375 ***
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2013-09-20 07:54:54 PDT
Marking dependent is probably a better way to track that.  Easier to remember to retest.
Comment 5 Alexandre BM (:rednaks) 2014-06-22 04:04:50 PDT
See bug 908375 comment 16

Note You need to log in before you can comment on or make changes to this bug.