Closed Bug 787045 Opened 7 years ago Closed 7 years ago

Camera and video cause FPS counter to go fuzzy, and sometimes, panning fps to drop

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: cjones, Assigned: kanru)

References

Details

Attachments

(1 file)

STR
 (1) Enable fps counter (Settings -> About phone -> Show fps)
 (2) Open camera app

The fps counter goes from sharp to fuzzy.  This quite surprising since the fps counter is drawn as an overlay on the framebuffer.  It looks as if some transform isn't being popped, or something odd like that.

This problem also reproduces with the video app, and on one phone it has been observed to affect homescreen panning fps.
Overload the ApplyFilterToBoundTexture function to accept a explicit aTarget
Attachment #656964 - Flags: review?(bgirard)
Attachment #656964 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/2c093c85e571
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.