Tabs close at a high speed if swiped both ways and then released to close

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: AdrianT, Assigned: lucasr)

Tracking

17 Branch
Firefox 19
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified)

Details

(Whiteboard: ui-responsiveness)

Reporter

Description

7 years ago
Firefox Mobile 16.0b1/ Aurora 18.0a1 2012-08-30
Device: Samsung Galaxy R (Android 2.3.4) / Samsung Galaxy Tab 2 7.0 (Android 4.0.4)

Steps to reproduce:
1. Open a few tab in order to have a few tries of reproducing this issue.
2. Open the Tab Menu.
3. Tap and hold on the tab swipe left and then drag right and release in a position to close the tab.

Expected results:
The tab closes at normal swipe to close speed.

Actual results:
The tab closes very fast, sometimes in the direction of the first drag opposite the side the user want's to dismiss it.

Note:
Please see the videocapture: http://youtu.be/gRQjlM0qccc
Assignee: nobody → wjohnston
Blocks: tab-slide
Assignee

Updated

7 years ago
Whiteboard: ui-responsiveness
Assignee

Updated

7 years ago
Assignee: wjohnston → lucasr.at.mozilla
Assignee

Comment 2

7 years ago
Landed: https://hg.mozilla.org/mozilla-central/rev/d15a22572dbd
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19

Comment 3

7 years ago
Verified on:
Firefox 20.0a1 (2012-12-07)
Device: Samsung Galaxy Tab 2 7.0
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
Assignee

Updated

7 years ago
Duplicate of this bug: 818494
You need to log in before you can comment on or make changes to this bug.